ТАУ Руководство к выполнению лабораторных работ: для заочного обучения

681.5(07)
Ф195 		VisSim.nm.ru & VisSim.com

Б. Т. Федосов

ТЕОРИЯ СИСТЕМ АВТОМАТИЧЕСКОГО
РЕГУЛИРОВАНИЯ

Руководство к выполнению лабораторных работ

Версия для заочного обучения


УДК 681.515(075.8) Ф195

УДК 681.515(075.8)
Ф195

Федосов Б. Т., Клиначёв Н. В. Теория систем автоматического регулирования: Руководство к выполнению лабораторных работ. - Offline версия 3.2 для заочного обучения. - Рудный, Челябинск, 2004. - 125 файлов, ил.

Пособие предназначено для студентов технических специальностей, изучающих курсы "Теория автоматического управления" (ТАУ), "Теоретические основы построения эффективных АСУ ТП", "Моделирование систем управления" и может быть рекомендовано студентам заочных отделений для самостоятельной проработки. Работы включают знакомство с программой VisSim, построение и анализ переходных и частотных характеристик типовых звеньев, а также исследование устойчивости линейной системы.

Ил. 93, учебных моделей 2, табл. 5, список лит. - 19 назв.

© Б. Т. Федосов, 2001-2004

Об авторстве

Данное пособие написано Федосовым Б. Т. доцентом кафедры "АТПиП" Рудненского индустриального института. Клиначёв Н. В. выполнил работу технического редактора: коррекция html-кода, разработка дизайна пособия, размещение информации о моделирующей программе VisSim и приглашений к членству в почтовых дискуссионных группах "Симуляция движения (моделирование)", "Цифровая обработка сигналов и LabVIEW".

Предисловие к версии

Учебное пособие выполнено в соответствии со стандартом Windows-HTML-справки. Оно представляет собой один файл, в котором заархивированы html-страницы, рисунки и необходимые скрипты. Файл пособия автоматически распознается и запускается операционной системой Windows 98 (NT, 2000), точнее браузером MSIE версии не ниже 4.0. Пользователям Windows 95 (NT) дополнительно следует установить Windows-HTML-справку. Для чего следует найти на сайте фирмы Microsoft файл hhupd.exe (716 KB). Там же, или в секторе "download" сайта фирмы Microsoft, вы можете скачать программу HTML Help Workshop (файл htmlhelp.exe (4 MB)). Используя ее, Вы можете декомпилировать пособие для запуска в браузере Netscape или для создания собственного на основе этого образца. Программа HTML Help Workshop также содержит утилиту для создания gif-файлов с изображениями необходимых вам фрагментов экрана. Для корректной цветопередачи при создании gif-файлов активируйте цветовое разрешение дисплея в 256 цветов. Пособие так же полностью функционально и запускается браузером MSIE, если в адресной строке набрать: mk:@MSITStore:C:\tau_lr_light.chm::/index.htm - где C:\ - путь к файлу tau_lr_light.chm.


ОГЛАВЛЕНИЕ

  1. Работа №1. ЗНАКОМСТВО С ПРОГРАММОЙ VisSim
  2. Работа №2. ИССЛЕДОВАНИЕ ЛИНЕЙНЫХ ТИПОВЫХ ЗВЕНЬЕВ
  3. Работа №3. ЧАСТОТНЫЙ АНАЛИЗ ТИПОВЫХ ЗВЕНЬЕВ
  4. Работа №4. ИССЛЕДОВАНИЕ УСТОЙЧИВОСТИ ЛИНЕЙНОЙ СИСТЕМЫ

ЛИТЕРАТУРА

  • Приложение А. VisSim - программа для моделирования систем
  • Приложение Б. Дискуссионная группа "Симуляция движения (моделирование)"
  • Приложение В. Дискуссионная группа "Цифровая обработка сигналов и LabVIEW"


Лаб.раб. № 1

Федосов Борис Трофимович

Лабораторная работа 1
ЗНАКОМСТВО С ПРОГРАММОЙ VisSim:
Построение и исследование простых виртуальных
лабораторных стендов

Цель и задачи работы

Цель работы: Знакомство с назначением, графическим интерфейсом, принципами построения моделей и важными блоками (виртуальными моделями реальных устройств и их элементов) программы VisSim, а также приобретение навыков создания простейших моделей, текстового и графического оформления диаграмм.

В результате выполнения работы следует сделать вывод о том, действительно ли виртуальные блоки программы VisSim и виртуальный лабораторный стенд в целом, с точки зрения исследователя воспринимаются и работают так же как их реальные аналоги.

Задачи работы:

  • Ознакомиться:
    • с назначением программного комплекса VisSim;
    • с графическим интерфейсом VisSim;
    • с принципами построения моделей в среде VisSim;
    • с основными видами блоков;
    • с принципами работы VisSim.
  • Выполнить:
    • создание надписей;
    • составление простейшей диаграммы;
    • анализ состоятельности (работоспособности) программы VisSim;
    • сохранение выполненной работы, печать.

1. Введение

Программа VisSim – одна из лучших программ объектно-ориентированного моделирования (ООМ) физических и технических объектов и систем. В частности, в этой программе могут быть промоделированы, исследованы и оптимизированы простые и сложные системы управления.

При подготовке и выполнении работы рекомендуется вначале ознакомиться с настоящей главной страницей целиком, а потом приступить к ознакомлению с теорией вопроса и выполнению задания, по мере необходимости обращаясь к более обстоятельному изложению, на которое даны ссылки.

Ознакомиться с основными понятиями и определениями, а также с интерфейсом и принципами работы программы VisSim можно на страницах, ссылки на которые приведены ниже:

  • Краткие сведения о структурно-объектном моделировании
    и о программном комплексе VisSim
    • 1.1. Назначение программы VisSim
    • 1.2. Графический интерфейс VisSim
    • 1.3. Принципы построения моделей в среде VisSim
    • 1.4. Основные блоки VisSim
    • 1.5. Принципы управления моделью и получения результатов моделирования
    • 1.6. Понятие о принципах функционирования программы VisSim
    • 1.7. Версии VisSim

2. Задание к работе

Работа рассчитана на одно-два занятия в компьютерном зале и два часа самостоятельной работы студента. Работа выполняется в компьютерном зале одним студентом или бригадой из двух-трех студентов, в зависимости от величины группы и возможностей компьютерного зала.

В результате выполнения экспериментальной части работы следует сделать вывод о том, действительно ли виртуальные блоки программы VisSim и виртуальный лабораторный стенд в целом работают и воспринимаются исследователем так же как их реальные аналоги.

Подробное изложение порядка выполнения работы и приемов работы с VisSim приведено на страницах по ссылкам:

    • 2.1. Запуск программы VisSim
    • 2.2. Помещение на рабочее пространство и редактирование надписей
    • 2.3. Создание, настройка и испытание простого виртуального лабораторного стенда
    • 2.4. Проверка работоспособности некоторых блоков
    • 2.5. Новая диаграмма
    • 2.6. Изменение продолжительности функционирования модели и шага интегрирования
    • 2.7. Полезные приемы и настройки
    • 2.8. Знакомство со справкой о программе VisSim и примерами диаграмм
    • 2.9. Выводы по проделанной работе и оформление отчета

I. Запустить программу VisSim двойным щелчком по файлу vissim32.exe (подробнее см. ссылку п. 2.1 выше).

II. Создать и исследовать простой виртуальный лабораторный стенд (диаграмму VisSim):

Рис. II.1. Первая диаграмма в законченном виде. Она содержит три генератора, осциллограф и четыре надписи

II. a. Создать содержательную пояснительную надпись (подробнее см. ссылку п. 2.2) о том, кто, когда, где и какую диаграмму выполнил.

II. b. Вынести на рабочее пространство VisSim’а генераторы синусоидального и постоянного сигналов, осциллограф и соединить их в нужном порядке (подробнее см. ссылку п. 2.3). Испытать работоспособность стенда (см. п. 2.3.3 - 2.3.7). Сохранить исходную диаграмму (п. 2.3.4).

II. c. Исследовать работоспособность генераторов и осциллографа (см. пп. 2.4.1 - 2.4.3). Сохранить диаграмму под новым названием. Сделать снимок экрана, обрезать должным образом, и сохранить рисунок, подобный рис. II.1 в формате gif в личной папке (см. п. 2.4.3).

III. Создать вторую диаграмму и исследовать измерительные приборы. Диаграмма должна иметь примерно такой вид:

Рис. III. 1 (анимация 26 кадров). Вторая диаграмма

Порядок создания диаграммы подробно рассмотрен в (п. 2.5). Сохранить диаграмму, дав ей содержательное название. Сделать снимок экрана и сохранить его в формате gif в личной папке.

Оценить точность отсчетов величин измеряемых сигналов и цифровым, и стрелочным приборами.

IV. Открыть первую диаграмму. В меню VisSim выбрать: File ® Open ® в откравшемся окне диалога перейти в свою личную папку ® указать требуемый файл ® щелкнуть по кнопке Открыть. Изменить время функционирования модели и шаг интегрирования. Подобрать их оптимальные значения (п. 2.6).

V. Познакомиться с дополнительными настройками осциллографа (п. 2.7) и порядком копирования и вставки на рабочее пространство фрагментов диаграммы (п. 2.7.2). Обратить внимание на возможности существенного повышения точности отсчетов координат точек на экране осциллографа (см. рис. 2.21 и ниже). Кроме того, познакомиться со способом последовательного вывода на экран осциллографа нескольких графиков (см. здесь).

VI. Познакомиться со справкой программы VisSim и примерами диаграмм (п. 2.8).

VII. О выводах и оформлении отчета (п. 2.9).

3. Отчет и защита работы

Отчет должен содержать:

  • титульный лист;
  • цель и задачи работы;
  • краткие сведения о программе VisSim;
  • диаграмму;
  • выводы.

Примечание: отчет предпочтительнее оформлять от руки, чертежным шрифтом, хотя допускается использование компьютера и принтера.

Защита работы включает доклад студента и его ответы на вопросы по теме лабораторной работы.

4. Домашнее задание

Подготовить бланк отчета:

  • Титульный лист;
  • Цели и задачи работы;
  • Основные теоретические сведения;
  • Предусмотреть место для задания и выводов.

Ответить на контрольные вопросы.

5. Контрольные вопросы

  1. Что такое модель и моделирование? С какой целью оно осуществляется?
  2. Для чего предназначена программа VisSim?
  3. Что представляет собой интерфейс VisSim'а?
  4. Из каких пунктов состоит главное меню VisSim'а? Их назначение.
  5. В чем заключаются принципы построения моделей в среде VisSim'а?
  6. Перечислите основные блоки VisSim'а. Почему они являются виртуальными аналогами реальных устройств и приборов?
  7. В чем состоят принципы управления моделью и получения результатов моделирования в среде VisSim'а?
  8. В чем заключаются принципы функционирования программы VisSim?
  9. Что нужно сделать, чтобы текст и надписи на рабочем пространстве VisSim'а были на русском языке?
  10. Как создать надпись на рабочем пространстве?
  11. Как изменить шрифт надписи на кириллицу?
  12. Как вынести на рабочее пространство VisSim'a генератор синусоиды? Как и какие параметры синусоиды можно изменить?
  13. Как соединять и разъединять блоки? Можно ли соединить два входа блоков или два выхода? Почему?
  14. Порядок вынесения на рабочее пространство и использования осциллографа. Как и какие настройки его можно менять? Как увеличить размер окна осциллогорафа на весь экран? Как еще можно повысить точность отсчитывания значений координат точек с экрана осциллографа?
  15. Как записать значения изображенной на осциллографе функции времени в файл?
  16. Что такое const и slider в VisSim'e? Чем похожи и чем отличаются эти генераторы?
  17. Что такое meter и display в VisSim'e? Когда предпочтительнее использовать тот или иной из этих индикаторов?
  18. Как изменить время функционирования (симуляции модели), т.е. время, в течение которого работает модель?
  19. Как изменить шаг интегрирования Step Size? Какой шаг интегрирования можно считать оптимальным? Как его подобрать?
  20. Как изменить количество точек на экране осциллогорафа?
  21. Как практически можно проверить состоятельность, работоспособность VisSim'a и отдельных его блоков?
  22. Как и где следует сохранять диаграммы VisSim'a? Чем отличается диаграмма VisSim'а от такого же снимка экрана?
  23. Какие версии VisSim'a Вы знаете?
  24. Где и как можно получить программу VisSim?


Лаб.раб. № 2

Федосов Борис Трофимович

Лабораторная работа 2
ИССЛЕДОВАНИЕ ЛИНЕЙНЫХ ТИПОВЫХ ЗВЕНЬЕВ

Цели работы: освоение методов анализа линейных систем с помощью программы Vissim; изучение основных характеристик типовых линейных звеньев.

Задачи работы: построение и анализ переходных характеристик интегратора, апериодического и колебательного звеньев.

Работа рассчитана на два двухчасовых занятия в компьютерном зале и два часа самостоятельной работы студента. Работа выполняется в компьютерном зале бригадой из одного – двух или трех студентов, в зависимости от величины группы и возможностей компьютерного зала.

1. Теоретические пояснения

Типовые звенья
Это простые модели элементов сложных линейных систем и даже систем вцелом.
Переходная характеристика звеньев
Переходная характеристика или функция позволяет и качественно, и количественно характеризовать быстродействие звеньев и систем. Переходный процесс может быть как монотонным, так и колебательным и его длительность и является количественной характеристикой быстроты реакции звена на прикладываемые к нему воздействия.

Типовые звенья бывают:

  • простейшие (пропорциональное звено, интегратор и дифференцирующее звено);
  • звенья первого порядка (апериодическое или инерционное, инерционно-дифференцирующее, форсирующее и др.);
  • звено второго порядка (колебательное и его частный случай – апериодическое второго порядка);
  • звено третьего порядка (способное терять устойчивость, его можно назвать звеном Вышнеградского);
  • звено запаздывания.

Основные характеристики линейных звеньев:

  • переходная характеристика h(t) - реакция звена на ступенчатое единичное воздействие 1(t);
  • передаточная функция W(s), связывающая изображения входного X(s) и выходного Y(s) сигналов линейного звена;
  • комплексный коэффициент передачи W(j w), связывающий спектры входного X(j w) и выходного Y(j w) сигналов линейного звена;
  • импульсная или весовая функция w(t) реакция звена на дельта-функцию Дирака d(t).

Интегратор – звено, выходной сигнал y(t) которого пропорционален интегралу по времени от входного сигнала x(t):

(1)

где: Т - т.н. постоянная времени интегратора.

Передаточная функция интегратора имеет вид [1]:

(2)

где: k - коэффициент усиления интегратора; s - комплексный аргумент.

Апериодическое звено имеет передаточную функцию вида [1]:

(3)

где: k - коэффициент усиления; Т - постоянная времени апериодического звена.

Колебательное звено имеет передаточную функцию вида [1]:

(4)

где: z (греческая дельта) - декремент затухания; k - коэффициент усиления; Т - постоянная времени.

Звено запаздывания задерживает сигнал на время t :

(5)

y(t) = x(t-t)

Его передаточная функция:

(6)

W(s) = e -t s

2. Задание к работе

  1. Построить в Vissim’e переходные характеристики интегратора, апериодического и колебательного звеньев.
  2. Проанализировать влияние изменения их параметров на переходные характеристики.

3. Порядок выполнения работы

Получить разрешение у преподавателя, ведущего занятия, и запустить VisSim.

Установить кириллицу: View - Font.

3.1. Исследование интегратора

Поместить в рабочее пространство Vissim следующие блоки:

  • генератор ступенчатого единичного воздействия 1(t): Blocks --> Signal Producer -> step;
  • интегратор: Blocks --> Integration -> integrator;
  • осциллограф: Blocks --> Signal Consumer --> plot.

Подключить выход step к входу integrator’а, выход integrator’а к входу plot’а.

Запустить программу на счет.

Обратите внимание, что величина коэффициента усиления или постоянная времени Т интегратора в Vissim’e не поддается изменению и всегда равна единице. При необходимости изменить эту величину следует перед интегратором поставить блок усиления gain: Blocks -> Arithmetic -> gain, в котором и поменять усиление, что будет эквивалентно изменению усиления k интегратора. Постоянная времени Т интегратора Т =1/k.

Как ведет себя переходная характеристика интегратора? Почему такое звено называется звеном без самовыравнивания?

Найдите связь между постоянной времени Т интегратора и временем, за которое его выходная величина достигает значения входной ступеньки. Сделайте выводы по проделанной части работы.

Оформление выполненной работы заслуживает очень большого внимания. Оно косвенно, но наглядно характеризует уровень профессионализма разработчика диаграммы. Поэтому этикетки и комментарии должны быть составлены и оформлены так, чтобы у наблюдателя диаграммы сложилось полное впечатление о том, кто, когда и зачем, с какой целью составил диаграмму, как работает модель, что на ней видно, каковы результаты моделирования и что из этого следует.

Оформите подписи и комментарии на диаграмме, включая и выводы. Сохраните диаграмму, дав ей содержательное краткое название, в своей папке (C:\Мои документы \ Учебные группы \ Группа№ …\ Иванов \ Лаб_раб №2). Предъявите диаграмму преподавателю, ведущему лабораторные работы.

3.2. Исследование апериодического звена

Открыть новую диаграмму VisSim.

Поместить в рабочее пространство VisSim следующие блоки:

  • генератор ступенчатого единичного воздействия 1(t): Blocks -> Signal Producer -> step;
  • блок линейной системы, или линейный блок, описываемый передаточной функцией W(s): Blocks -> Linear System -> Transfer Function;
  • осциллограф: Blocks -> Signal Consumer -> plot.

Подключить step к входу блока Transfer Function, а его выход к входу осциллографа plot.

Пусть требуется исследовать апериодическое звено с передаточной функцией:

, где k = 4,7; T = 0,2 с.

Настроить линейный блок: дважды щелкнуть по блоку левой кнопкой мыши или один раз правой. В появившемся окне установить: усиление (Gain) равным 4.7, числитель (Numerator) оставить равным 1, для знаменателя (Denominator) набрать 0.2 (пробел) 1. Символы "s" и "+" в знаменателе не указываются, они по принятому в VisSim соглашению заменяются при вводе одним пробелом. Нажать ОК.

Запустить на счет.

Проанализировать график переходной функции. Найти соотношение между постоянной времени Т апериодического звена и временем, за которое переходная функция приближается к своему установившемуся значению на величину, меньшую 5% этого значения. Как еще по переходной характеристике апериодического звена можно определить значение постоянной времени?

Подключить несколько звеньев к одному осциллографу. Рассмотреть варианты с различными значениями коэффициента усиления и постоянной времени (0.01, 0.05, 0.1, 0.5, 1.0, 5.0, 10.0, 50.0, 100.0 сек) апериодического звена. Сделать выводы.

Оформить диаграмму, включая заголовок главного окна осциллографа и названия отдельных кривых переходного процесса. Сохранить диаграмму, предъявить преподавателю.

3.3 Исследование колебательного звена

Передаточная функция колебательного звена имеет вид:

Построить переходную характеристику колебательного звена для k =7.8; Т =1, 0.2 и 5.0, при изменении затухания z от 0.25 до 2.0.

Оценить влияние изменения параметров передаточной функции колебательного звена на вид и длительность его переходной характеристики.

Открыть новую диаграмму VisSim.

Поместить в рабочее пространство Vissim следующие блоки:

  • генератор ступенчатого единичного воздействия 1(t): Blocks -> Signal Producer -> step;
  • блок линейной системы, или линейный блок, описываемый передаточной функцией W(s): Blocks -> Linear System -> Transfer Function;
  • осциллограф: Blocks -> Signal Consumer -> plot.

Подключить step к входу блока Transfer Function, а его выход к входу осциллографа plot.

Настроить линейный блок: дважды щелкнуть по блоку левой кнопкой мыши или один раз правой. В появившемся окне установить: усиление (Gain) равным 7.8, числитель (Numerator) оставить равным 1, для знаменателя (Denominator) в случае, когда Т=0.2 и z=2 набрать 0.04 (пробел) 0.8 (пробел) 1. Символы "s2" и "+", а также "s" и "+" в знаменателе не указываются, они по принятому в VisSim соглашению заменяются при вводе пробелами. Нажать ОК.

Запустить на счет.

Проанализировать графики переходных функций подобно тому, как это делалось ранее.

Проанализировать результаты, оформить и сохранить (см. выше) в специально созданной папке работу. Предъявить преподавателю и защитить.

3.4. Звено запаздывания

Это звено часто встречается в моделях реальных систем и зачастую его присутствие ухудшает свойства системы по сравнению с тем, как если бы его не было. Поэтому, если в реальной системе имеется такой элемент, то для обеспечения адекватности модели важно ввести его и в модель.

  1. Поместить в новое рабочее пространство блок задержки: Blocks -> Time Delay -> timeDelay.
  2. Поместить слайдер, генератор ступеньки и осциллограф. На вход х блока задержки подать ступеньку, на вход t подключить слайдер (полосу прокрутки числовых значений) и выход блока подключить к осциллографу.
  3. Изменяя задержку и запуская на счет посмотреть осциллограммы.
  4. Сделать выводы.

4. Отчет и защита работы

  1. Отчет должен содержать:
    • титульный лист;
    • цель и задачи работы;
    • диаграмму;
    • выводы.
  2. Защита работы включает доклад студента и его ответы на вопросы по теме лабораторной работы.

Примечание: отчет предпочтительнее оформлять от руки, чертежным шрифтом, хотя допускается использование компьютера и принтера.

5. Домашнее задание

  1. Подготовить бланк отчета:
    • Титульный лист;
    • Цели и задачи работы;
    • Основные теоретические сведения;
    • Предусмотреть место для задания и выводов.
  2. Ответить на контрольные вопросы.

6. Контрольные вопросы

  1. Каковы цели и задачи работы?
  2. Что такое типовые звенья линейных систем? Для чего они используются?
  3. Какие типы звеньев Вы знаете?
  4. Какие характеристики звеньев Вы знаете?
  5. Что такое ступенчатое единичное воздействие 1(t)?
  6. Что такое переходная характеристика звена? Что она может характеризовать?
  7. Что такое интегратор, апериодическое звено, колебательное звено? Как выглядят их переходные характеристики?
  8. Как построить в среде VisSim блок-схему, позволяющую определить реакцию интегратора на ступенчатое воздействие? А на синусоидальное воздействие?
  9. Порядок определения переходной характеристики апериодического звена.
  10. Порядок определения переходной характеристики колебательного звена.
  11. Какие свойства осциллографа plot можно поменять для улучшения наглядности графика?
  12. Как изменить число точек на графике? Что при этом следует контролировать? Как сохранить значения координат точек графика в файле?
  13. Где и как следует сохранять созданную, оформленную отлаженную и отредактированную программу?

Приложение

На рисунке, в режиме анимации демонстрируется пример блок-схемы открытой в версиях программы VisSim: 2.0k, 3.0 FAP, и в русифицированной (платной) версии 4.5. Блок-схема иллюстрирует получение переходных характеристик апериодических звеньев. Анимацию можно остановить кнопкой "стоп" браузера.


Лаб.раб. № 3

Федосов Борис Трофимович

Лабораторная работа 3
ЧАСТОТНЫЙ АНАЛИЗ ТИПОВЫХ ЗВЕНЬЕВ

Цели работы: освоение методов анализа линейных систем с помощью программы Vissim; изучение частотных характеристик типовых линейных звеньев.

Задачи работы: построение и анализ логарифмических амплитудно-частотной (ЛАЧХ) и фазочастотной (ЛФЧХ) характеристик апериодического и колебательного звеньев.

Работа рассчитана на два – четыре часа занятий в компьютерном зале и два часа самостоятельной работы студента. Работа выполняется в компьютерном зале бригадой из одного – двух или трех студентов, в зависимости от величины группы и возможностей компьютерного зала.

1. Теоретические пояснения

Комплексный коэффициент передачи W (j w) связывает спектры входного X (j w) и выходного Y (j w) сигналов линейного звена:

Y (j w) = W (j w) X (j w) = |W (j w)| e -j(w) X (j w) ,

где: |W (j w)| - модуль комплексного коэффициента передачи; j(w) - аргумент комплексного коэффициента передачи.

Зависимость величины усиления звеном синусоидального сигнала от частоты этого сигнала, т.е. зависимость модуля комплексного коэффициента передачи |W(j w)| от частоты называется амплитудно-частотной характеристикой (АЧХ) звена. Такая характеристика, построенная в логарифмической системе координат, называется логарифмической амплитудно-частотной характеристикой (ЛАЧХ). Другими словами, ЛАЧХ – это зависимость 20Lg |W(j w)| (двадцати логарифмов модуля комплексного коэффициента передачи) от частоты.

Фазочастотная характеристика (ФЧХ) звена это зависимость аргумента j(w) его комплексного коэффициента передачи от частоты. ФЧХ показывает, на какую величину отстанет по фазе синусоидальный сигнал некоторой частоты, пройдя линейное звено, от входного сигнала. Эта характеристика также может быть построена в логарифмической системе координат, в этом случае она называется ЛФЧХ.

АЧХ и ФЧХ или ЛАЧХ и ЛФЧХ, как правило, изображаются парами, друг под другом. Это повышает наглядность и упрощает анализ свойств отдельных звеньев и систем.

2. Задание к работе

Определение частотных характеристик апериодического и колебательного звеньев.

2.1. Апериодическое звено

Построить в среде VisSim, проанализировать и распечатать ЛАЧХ и ЛФЧХ апериодического звена.

2.1.1. Открыть диаграмму с исследованием апериодического звена, сохраненную на предыдущем занятии.

Примечание. Заново установить кириллицу. Выделить блок апериодического звена, нажав левую кнопку мыши за его пределами и расширив рамку до включения в нее блока. Отпустить кнопку. Блок станет черным. В меню: Analyze --> Frequecy Response. На рабочем пространстве появятся два графика, представляющие собой ЛАЧХ и ЛФЧХ. Растянуть их и поместить в правой части экрана друг под другом (см. пример в Приложении). Ввести сетку координат: plot --> двойной щелчок --> Grid Lines – установить флажок. Нажать OK. На верхнем графике, ЛАЧХ, установить по оси ординат значение в децибелах.

2.1.2. Для нижнего графика, ЛФЧХ установить значение Y Lower Bound равным -90 градусов. Поставить флажок Fixed Number of Divisions, установить значение Y Divisions равным 6. Нажать OK.

2.1.3. Сделать подписи графиков, кривых, осей. Установить белый цвет фона. Сохранение. Нажать клавишу клавиатуры Print Screen. Открыть Paint (Пуск --> программы --> стандартные --> Paint). Выбрать: Правка --> Вставить. При необходимости, вырезать в Paint’e лишние части и, нужное, сохранить (по возможности в gif-формате) и распечатать.

Примечание. Распечатку можно производить и из VisSim’a, но при этом распечатывается на весь лист лишь один из графиков, что не всегда удобно и необходимо.

Диаграмму в VisSim’e можно сохранить (в View --> Display Mode) и как картинку с расширением .wmf, а затем распечатать.

В демо-версии VisSim 4.5 можно распечатать блок-схему с временными диаграммами, но там отсутствует возможность анализа частотных характеристик.

В версии VisSim 2.0k частотные характеристики не сохраняются, поэтому работа через Print Screen --> Paint только и позволяет получить распечатку.

Проанализировать влияние постоянной времени и коэффициента усиления апериодического звена на вид его частотных характеристик. Найти, как по ЛАЧХ и по ЛФЧХ апериодического звена определить его постоянную времени и коэффициент усиления. Предъявить выполненную работу преподавателю.

2.4. Колебательное звено

2.4.1. Открыть диаграмму с исследованием колебательного звена, сохраненную на предыдущем занятии. Примечание. Заново установить кириллицу.

2.4.2. Построить ЛАЧХ и ЛФЧХ для T =1, k=1 и z= 0.25; 0.5; 0.707, 1.0; и для 2.0.

2.4.3. Получить количественную зависимость высоты "пика" на ЛФЧХ от величины декремента затухания z колебательного звена, имеющего передаточную функцию:

.

2.4.4. Оформить диаграмму, не забыть указать, кто и когда ее сделал. Написать выводы и сохранить работу, предъявить ее преподавателю.

3. Отчет и защита работы

  1. Отчет должен со держать:
    • титульный лист;
    • цель и задачи работы;
    • диаграмму;
    • выводы.
  2. Защита работы включает доклад студента и его ответы на вопросы по теме лабораторной работы.

Примечание: отчет предпочтительнее оформлять от руки, чертежным шрифтом, хотя допускается использование компьютера и принтера.

4. Домашнее задание

  1. Подготовить бланк отчета:
    • Титульный лист;
    • Цели и задачи работы;
    • Основные теоретические сведения;
    • Предусмотреть место для задания и выводов.
  2. Ответить на контрольные вопросы.

5. Контрольные вопросы

  1. Что такое ЛАЧХ?
  2. Что такое ЛФЧХ?
  3. Как построить ЛАЧХ линейного звена в Vissim'e?
  4. Как построить ЛФЧХ линейного звена в Vissim’e?
  5. Как влияет постоянная времени апериодического звена на ширину его полосы пропускания?
  6. Чему равен фазовый сдвиг (аргумент комплексного коэффициента передачи) апериодического звена на частоте w=1/T ?
  7. Записать выражения для передаточных функций апериодического и колебательного звеньев, пояснить названия и смысл параметров.
  8. Какое значение декремента затухания минимизирует длительность переходного процесса колебательного звена?

Приложение

Пример ЛАЧХ и ЛФЧХ, построенных в программе VisSim.

Увеличение постоянной времени апериодического звена приводит к пропорциональному увеличению длительности переходного процесса и пропорциональному уменьшению полосы пропускания и частоты среза


Лаб.раб. № 4

Федосов Борис Трофимович

Лабораторная работа 4
ИССЛЕДОВАНИЕ УСТОЙЧИВОСТИ ЛИНЕЙНОЙ СИСТЕМЫ

Цель работы: изучение методов анализа устойчивости и коррекции линейной системы.

Задачи работы: построение модели линейной системы; анализ частотных характеристик; коррекция системы; построение годографа комплексного коэффициента передачи контура (годографа Найквиста) системы.

1. Теоретические пояснения

Линейные системы, содержащие контур из устойчивых звеньев могут быть неустойчивыми. В системах управления неустойчивость, как правило, является недопустимой, вредной. В системах генерации неустойчивость напротив, необходима.

Определение: по Ляпунову система устойчива, если по окончании воздействия она возвращается в исходное состояние.

Существуют т.н. критерии устойчивости – правила, позволяющие узнать, будет ли система устойчивой или нет по ее модели. Критерии бывают алгебраические (Гурвица, Рауса) и частотные (Михайлова, Найквиста).

По критерию Найквиста для устойчивости замкнутой системы необходимо и достаточно, чтобы годограф комплексного коэффициента передачи разомкнутого контура не охватывал на комплексной плоскости точку с координатами (-1, j0). При этом необходимо, чтобы разомкнутый контур был устойчив.

В логарифмическом варианте формулировки критерия Найквиста для устойчивости системы необходимо и достаточно чтобы частота среза wср была меньше частоты wp [1].

Для получения системы управления хорошего или, по крайней мере, удовлетворительного качества, необходимо выполнить три условия:

  • запас g устойчивости по фазе должен составлять 350..650 и более;
  • запас L устойчивости по амплитуде должен быть 6..12..20 дБ и более;
  • если система статическая, то усиление ее контура должно находиться в пределах 20..40 дБ.

2. Задание к работе

2.1. Оценить устойчивость и качество системы автоматического регулирования (САР), модель которой содержит контур, состоящий из трех апериодических звеньев рис.1:

Рис. 1. Модель САР в виде замкнутого контура, содержащего три апериодических звена и пропорциональное звено в обратной связи

Передаточная функция апериодического звена имеет вид [1]:

.

Исходные значения параметров передаточных функций звеньев системы для разных бригад приведены в таблице.

№ бригады | k1 | k2 | k3 | T1 | T2 | T3 | kос
1 | 7.00 | 7.20 | 2.40 | 0.02 | 0.50 | 6.20 | 0.24
2 | 8.10 | 6.40 | 2.80 | 0.018 | 0.43 | 5.90 | 0.24
3 | 6.5 | 7.7 | 2.12 | 0.024 | 0.52 | 7.3 | 0.24
4 | 7.1 | 6.2 | 2.5 | 0.03 | 0.60 | 8.2 | 0.24
5 | 6.8 | 7.4 | 2.9 | 0.01 | 0.63 | 5.45 | 0.24

3. Порядок выполнения работы

3.1. Составить схему рис. 1 в среде VisSim.

3.1.1. Вынести на рабочее пространство:

  • генератор ступенчатого воздействия (step),
  • сумматор ( Blocks ® Arithmetic ® Summing Junction), поменять знак суммирования у нижнего входа сумматора на отрицательный (подведя курсор, щелкнуть правой кнопкой мыши).
  • три линейных блока (transfer Function), задать значения параметров,
  • усилитель (Blocks ® Arithmetic ® gain). Повернуть усилитель в противоположную сторону (выделить его, Edit ® Rotate 1800).
  • осциллограф (plot),
  • установить шрифт View ® Font ® Кириллица (полужирный).

3.1.2. Соединить все блоки в соответствии с рис.1. Установить значения параметров блоков.

3.1.3. Запустить на счет. Подобрать значения времени развертки осциллографа для полного представления переходного процесса. Устойчива ли система? Почему?

3.2.1. Определить запасы устойчивости САР по амплитуде и фазе.

Построить ЛАЧХ и ЛФЧХ:

  • Выделить блоки контура;
  • Analyze ® Frequency Response. Появятся графики ЛАЧХ и ЛФЧХ .

Растянуть их и убедиться, что диапазон частот достаточен, в противном случае, меняя пределы графика, добиться нужных значений: Analyze ® Frequency Range.

Примечание: После изменения пределов сетки координат следует вновь построить ЛАЧХ и ЛФЧХ. ЛАЧХ и ЛФЧХ не изменяются при изменении параметров графиков или звеньев, не сохраняются при сохранении диаграммы, поэтому их каждый раз приходится строить заново.

Оформить графики, растянуть, ввести сетки координат, амплитудную характеристику представить в децибелах, на ЛФЧХ установить предел по вертикали -2700, ввести фиксированное число делений сетки и установить для вертикальной оси это значение в 6 или 9, ввести подписи.

Определить запасы устойчивости:

  • по амплитуде L - это расстояние в децибелах от оси частот до ЛАЧХ на частоте wp, на которой ЛФЧХ пересекает уровень -1800.
  • по фазе g. Это расстояние от ЛФЧХ до уровня –1800 на частоте среза wср, когда ЛАЧХ пересекает ось частот.

3.2.2. Изменяя общий коэффициент усиления контура посредством увеличения и уменьшения коэффициента усиления первого звена, изучить, как это сказывается на степени устойчивости системы. Контроль осуществлять по переходной характеристике.

3.2.3. Скорректировать САР. Определить оптимальное значение коэффициента усиления контура, при котором запасы по фазе и амплитуде войдут в рекомендуемые диапазоны (см. выше). Установить это значение усиления и построить переходную характеристику оптимизированной САР, а также ЛАЧХ и ЛФЧХ.

3.2.4. Оформить диаграмму, предъявить ее преподавателю, сохранить в своей папке.

3.3. Построить области устойчивости системы рис. 1. по коэффициенту усиления контура k = k1 k2 k3.

3.3.1. Принять k2=1, k3=1, T1=1. Значение k1 выбрать из таблицы 2.

Таблица 2 Коэффициенты усиления контура k=k1
№ бригады | Величина коэффициента k1
1 | 8
2 | 10
3 | 20
4 | 50
5 | 100

3.3.2. Изменяя T2 и T3 в пределах от 0.01 до 1.0 (0.01, 0.02, 0.04, 0.06, 0.08, 0.10 , 0.2, 0.4, 0.6, 0.8, 1.0) определить устойчива ли система, и заполнить таблицу 3.

Таблица 3. Состояние устойчивости САР при различных значениях постоянных времени
 | T3=0.01 | T3=0.02 | … | T3=1.0
T2=0.01 | Уст. (неустойчива) | Уст. (неустойчива) |  |
T2=0.02 |  |  |  |
T2=0.04 |  | Уст. (неустойчива) |  |
… |  |  |  |
T2=1.0 |  |  | Уст. (неустойчива) |

Далее следует уточнить местоположение кривой на рис. 2.

3.3.3. Построить график-диаграмму области устойчивости САР при заданном коэффициенте усиления. Его примерный вид показан на рис. 2.

Рис. 2. Область устойчивости САР третьего порядка. Система с близкими значениями постоянных времени находится ближе к потере устойчивости, чем система с сильно отличающимися постоянными времени

3.4. Построить и проанализировать годограф комплексного коэффициента передачи контура:

  • Выделить контур регулирования.
  • Объединить выделенные элементы в один блок: Edit ® Create Compound Block.
  • Подписать название блока (предварительно, если необходимо, установить шрифт View ® Font ® Кириллица (полужирный).
  • Выделить составной (Compound) блок.
  • Создать график: (Analyze ® Nyquist Response), провести оси координат, растянуть график.
  • Для просмотра некоторой части графика следует ее выделить (Ctrl + левая кнопка мыши и провести курсором по диагонали увеличиваемой области). Ctrl + правая кнопка возвращает исходный масштаб.

Проанализировать годограф, предъявить преподавателю.

4. Отчет и защита работы

  1. Отчет должен содержать:
    • титульный лист;
    • цель и задачи работы;
    • диаграмму;
    • выводы.
  2. Защита работы включает доклад студента и его ответы на вопросы по теме лабораторной работы.

Примечание: отчет предпочтительнее оформлять от руки, чертежным шрифтом, хотя допускается использование компьютера и принтера.

5. Домашнее задание

  1. Подготовить бланк отчета:
    • Титульный лист;
    • Цели и задачи работы;
    • Основные теоретические сведения;
    • Предусмотреть место для задания и выводов.
  2. Ответить на контрольные вопросы.

6. Контрольные вопросы

  1. Какова минимальная степень системы, состоящей из устойчивых элементов, способной быть неустойчивой?
  2. Какие запасы устойчивости следует обеспечить, чтобы качество САР было удовлетворительным?
  3. Как построить ЛАЧХ и ЛФЧХ в среде VisSim?
  4. Как создать составной блок, т.е. объединить несколько блоков в одном? Как повернуть блок на диаграмме на 1800?

Приложение

Примеры диаграмм приведены ниже:

Как видно из диаграммы, увеличение коэффициента усиления контура САР повышает колебательность ее переходной характеристики, т.е. приближает к потере устойчивости и, одновременно, уменьшает ошибку регулирования в установившемся режиме.

Для получения ЛАЧХ и ЛФЧХ необходимо выделить контур САР (показан черным цветом).


Литература

Литература и Интернет

Основные источники

  1. Официальный сайт фирмы Visual Solution Inc.:
    http://www.vissim.com/
    Бесплатная академическая версия VisSim 3.0
    http://www.vissim.com/products/academic.html
  2. Программный комплекс "МВТУ"
    http://energy.power.bmstu.ru/mvtu/
    Федосов Б.Т. КРАТКОЕ ЗНАКОМСТВО С ПК "МВТУ"
    http://energy.power.bmstu.ru/mvtu/zip/mbty_intr.chm (368 КБ)
  3. Студенческая версия программы VisSim
    http://www.vissim.nm.ru/download.html
  4. Центр загрузки русифицированной версии программы VisSim
    http://vissim.exponenta.ru/
  5. Федосов Б.Т. Первое знакомство с компьютером.
    Windows: Рабочий стол. Стандартные программы: Блокнот, Калькулятор, Paint.
    http://www.cise.gasu.ru/library/it/begin/Win_Beg.zip (1.12 МБ), 2004
  6. Н. В. Клиначёв. МОДЕЛИРОВАНИЕ СИСТЕМ В ПРОГРАММЕ VisSim
    Справочная система на русском языке. 2001.
    http://vissim.nm.ru/ vsmhlpru.zip (877 КБ)
  7. VisSim User's Guide - Version 3. Visual Solutions Inc., Westford, MA 01886 USA. 1998, 330 p.

Дополнительные источники

  1. Лукас В.А. Теория автоматического управления. – М.: Недра, 1990. – 416 с.
  2. Иванов А.А. ТАУР. М., Недра, 1970, 352 с.
  3. Топчеев Ю.И., Цыпляков А.П. Задачник по ТАУ. М.: Машиностроение, 1977.-592с.
  4. Юревич Е.И. ТАУ. Энергия, Ленинград, 1975, 416 с.
  5. ТАУ. Под ред. Воронова А.А. ч.1. М.: Высш.шк., 1986, 367 с.
  6. Клюев А.С. Автоматическое регулирование. М., Энергия, 1973.
  7. ТАУ. Ред. Нетушил А.В. М., Высш. шк., 1976, 400 с.
  8. Брюханов В.Н. и др. Теория автоматического управления. – М: Высшая школа, 2000 г.
  9. Сайт кафедры АТПП РИИ
    http://web.host.kz/atpp или http://www.web.host.kz/atpp.
  10. Федосов Б.Т. Задания и методические указания к выполнению курсовой работы по курсу ТАУ. Рудный, РИИ, 1996, - 32 с.
  11. Федосов Б.Т., Клиначев Н.В. О построении области устойчивости линейной системы по некоторому параметру стандартными средствами программ математического моделирования. 2002 г. http://vissim.nm.ru/d_region.html
  12. Федосов Б.Т. Оценка качества установившегося режима САР. 2003 г. http://www.vissim.nm.ru/bt/bt_0004.html


Глоссарий терминов

Автоматическое регулирование
Поддержание постоянной (стабилизация) или меняющейся во времени по некоторому закону (слежение) величины, характеризующей объект управления.
Автоматическое управление
Это подача на объект управления совокупности воздействий с целью обеспечения оптимального, в некотором смысле, функционирования объекта. Совокупность воздействий выбирается из множества возможных.
Адекватность модели
Соответствие модели реальной системе. Достигается только с некоторой точностью.
Апериодическое (инерционное) звено
Это звено - простейшее из моделей линейных систем, обладающих инерционностью. Функционально звено содержит один накапливающий (реактивный) элемент и хотя бы один рассеивающий (активный).
Весовая функция
Реакция линейной системы или звена на дельта-функцию Дирака (на практике - на достаточно короткий импульс).
Возмущение
Воздействие, поступающее на объект управления, препятствующее его требуемому поведению.
Задающая величина
Величина, подаваемая на вход системы регулирования. В соответствии с задающей величиной должна изменяться выходная, управляемая величина объекта управления.
Замкнутая САР с управлением по отклонению
Система управления, в которой регулятор вырабатывает управляющие воздействия на объект на основе определения отклонения управляемой величины от задающей.
Звено запаздывания
Устройство, выходной сигнал которого, оставаясь неизменным по форме и масштабу, отстает по времени от входного на некоторую величину.
Интегратор
Звено, выходной сигнал которого пропорционален интегралу по времени от входного. Например, емкость, в которую поступает жидкость, или вал двигателя.
Колебательное звено
Простейшее из линейных систем, обладающих колебательностью, т.е. способностью колебательно возвращаться в исходное состояние после прекращения воздействия. Состоит из двух реактивных элементов, способных накапливать энергию в разных фазах и хотя бы одного активного элемента, способного ее рассеивать.
Комплексный коэффициент передачи
Функция мнимого аргумента, связывающая спектры входного и выходного сигналов линейного звена.
Амплитудно-частотная характеристика (АЧХ)
Зависимость модуля комплексного коэффициента передачи некоторого звена от частоты. Другими словами, это зависимость усиления звеном синусоидального сигнала от частоты этого сигнала.
Контролируемая величина
Величина, характеризующая объект управления и измеряемая в процессе управления объектом. Неконтролируемая величина - не измеряется.
ЛАЧХ (логарифмическая амплитудно-частотная характеристика)
Это АЧХ, построенная в логарифмическом масштабе.
ЛФЧХ (логарифмическая фазочастотная характеристика)
ФЧХ, построенная в полулогарифмическом масштабе (т.е. только частота
откладывается в логарифмическом масштабе).
Линейная система
Это такая, в которой сумме воздействий соответствует реакция, равная сумме реакций на каждое из них, а некоторому изменению воздействия соответствует пропорциональное изменение реакции, т.е. любая линейная система подчинятся принципу суперпозиции. Большинство систем и объектов при достаточно малых воздействиях можно считать линейными.
Модель линейной системы
Совокупность структурно-алгоритмической схемы и передаточных функций ее звеньев или передаточная функция всей системы.
Начальное условие
Значение сигнала на выходе интегратора в момент начала решения дифференциального уравнения (в момент начала симуляции в VisSim'е). Физически - это может быть ток в катушке или напряжение на конденсаторе к моменту коммутации цепи, или уровень (объём) воды в водохранилище к моменту начала сброса.
ОС - обратная связь
Связывает выход элемента или некоторой совокупности элементов с их входом.
ООС - отрицательная обратная связь
Входной сигнал охватываемого ей звена получается вычитанием из входного воздействия выходного сигнала звена или его части. ООС может повысить стабильность системы регулирования.
Объект управления
Машина, механизм, устройство и т.п., способные воспринимать внешние воздействия и реагировать на них изменением некоторой величины, характеризующей объект, например, температуры, напряжения, пространственной координаты и др.
Параметр
Численная величина, характеризующая систему или ее элемент, например, коэффициент усиления, постоянная времени.
Передаточная функция
Функция комплексного аргумента, связывающая изображения Лапласа входного и выходного сигналов линейного звена.
Переходная функция или характеристика
Реакция линейного звена на ступенчатое единичное воздействие.
Предмет ТАУ
Анализ и синтез систем автоматического управления.
Анализ системы управления
Изучение ее структуры, свойств и характеристик. Осуществляется на основе построения моделей системы управления.
Программное управление
Воздействие на объект таким образом, чтобы величина, его характеризующая изменялась во времени в соответствии с заранее известным законом.
ПОС - положительная обратная связь
Входной сигнал охватываемого ей звена получается сложением с воздействием выходного сигнала этого звена или части выходного сигнала. В ТАУ, ПОС зачастую нежелательна, поскольку может привести к потере системой устойчивости.
Разомкнутая САР с управлением по возмущению
Система управления, в которой регулятор вырабатывает управляющие воздействия на объект на основе возмущений, действующих на объект. Информация о реальном значении управляемой величины в регулятор не поступает.
Регулирование
Поддержание постоянной или изменяющейся по некоторому закону величины, характеризующей объект управления.
Синтез системы
Построение теоретической модели проектируемой САР, соответствующей требуемым критериям ее качества.
Система (в ТАУ)
Совокупность элементов (звеньев), взаимодействующих между собой и предназначенная для выполнения функций управления, в частности, регулирования и стабилизации. Главный элемент - объект управления. Важный элемент - регулятор.
Структурная схема (структурно-алгоритмическая схема)
Теоретическая модель реальной системы, представляющая собой блок-схему, в которой звенья соответствуют математическим операциям преобразования сигналов, а стрелки указывают направление передачи информации. Для одной системы может быть построено несколько эквивалентных и адекватных структурных схем.
Устойчивость системы
Способность системы возвращаться в устойчивое состояние по окончании воздействия.
Управляемая величина
Величина, характеризующая объект управления и изменяющаяся под воздействием управляющей величины.
Управляющая величина
Величина, поступающая на вход объекта управления.
Функциональная схема
Блок-схема, состоящая из блоков, соответствующим функциональным, физическим элементам системы управления, в которой стрелки указывают направление передачи энергии.
ФЧХ
Зависимость аргумента комплексного коэффициента передачи некоторого звена от частоты. Другими словами, это зависимость фазовой задержки синусоидального сигнала при прохождении им линейного звена, от частоты.


VisSim - программа для моделирования систем

VisSim - ПО для симуляции систем. Имеет частотные, корневые, вариационные, нейронные инструменты оценки качества, устойчивости, синтеза, коррекции, оптимизации, линеаризации, программирования цифровых сигнальных процессоров, отладки объектов в контуре модели.

Программа VisSim русифицирована (включая систему контекстной справки) и широко используется в учебном процессе в вузах России. На рисунках показаны фрагменты, визуально демонстрирующие возможности программы.

Частотные характеристики типовых динамических звеньев

Типовые динамические звенья

где:

1) W(s) = K
5) W(s) = K
1+T2s2
8) W(s) = K(1+Ts)
s
2) W(s) = K
1+Ts
6) W(s) = K
s
9) W(s) » Ks
3) W(s) = K
(1+T3s)(1+T4s)
7) W(s) = K
s(1+Ts)
10) W(s) = Ks
(1+Ts)

4) W(s) =

K ; где: 0 < e < 1; q=1/T
1+2eTs+T2s2

Блок-схемы цифровых фильтров построенные на основе блоков 'регистрЗадержки' и 'передаточнаяФункция'

VisSim в вузах России

Фирма Visual Solusions открыла для Российских вузов бесплатную академическую программу распространения пакета VisSim. Воспользовавшись ей, многие кафедры внедрили этот пакет в свой учебный процесс. VisSim позволяет поднять показатели качества учебного процесса для курса "Теория систем автоматического регулирования" на принципиально новый уровень.

VisSim в вузах России

Владивосток
Дальневосточный государственный технический университет
Кемерово
Сибирский государственный технический университет
Красноярск
1. Институт металлургии
2. Сибирский технологический университет
Лысьва
Филиал Пермского государственного технического университета
Москва
Московский государственный технический университет
Новороссийск
Новороссийская государственная морская академия
Новочеркасск
Новочеркасский политехнический институт
Оренбург
Оренбургский государственный университет
Пермь
Пермский государственный технический университет
Рудный (Казахстан)
Рудненский индустриальный институт
контакт: Федосов Борис Трофимович
кафедра "Автоматизаця технологических и производственных процессов"
Рязань
Рязанская государственная академия радиосвязи
Самара
Самарский государственный технический университет
Санкт-Петербург
Санкт-Петербургский государственный университет
Смоленск
Московская государственная технологическая академия
Уфа
Уфимский государственный авиационный технический университет
Хабаровск
Дальневосточный государственный университет путей сообщения
контакт: Малай Геннадий Порфирьевич
(кафедра Автоматика и телемеханика)
Челябинск
1. Южно-Уральский государственный университет
контакт: Клиначёв Николай Васильевич
2. Челябинский государственный университет

Расширения программы VisSim

VisSim Viewer
Версия пакета VisSim для просмотра моделей и для поддержки обмена моделями между пользователями. Имеющий лицензию пользователь может передать лицензированный Viewer своему коллеге, неимеющему лицензии. Viewer бесплатно доступен с сайта изготовителя. Ограничения Viewer-а состоят в том, что невозможно записать модель, выполнить частотный анализ, изменить структуру модели, но допустимо менять параметры модели. Режим симуляции движения полностью функционален.
VisSim/Analyze
Первый по важности и очень важный дополнительный продукт пакета VisSim, который позволяет выполнить наиболее распространенные виды частотного анализа: ЛАЧХ & ЛФЧХ, годограф Найквиста, корневой годограф - для построенной пользователем модели или ее фрагментов. Данный инструментарий в FAP-версии применим только к моделям, составленным из линейных блоков. Для анализа динамика нелинейных моделей аппроксимируется линеаризованной передаточной функцией или ABCD пространством состояний. Имеется возможность синтеза компенсационных (корректирующих) устройств редактированием нулей и полюсов в интерактивном режиме.
VisSim/OptimizePRO
Небольшой удобный инструментарий, позволяющий по результатам повторных моделирований выполняемых при вариациях параметров автоматически подобрать оптимальные для системы. Например - коэффициенты ПИД-регулятора. Пользователю требуется самостоятельно составить функцию цены из стандартных блоков программы - любую оценку качества - обычно это квадратичные интегральная или улучшенная интегральная оценки, но возможны и другие.
VisSim/NeuralNet
Инструментарий применимый для идентификации нелинейных систем, в прикладной диагностике, при принятии решений, предсказании, и в других задачах, где распознавание образов требует численных решений.
VisSim/C-Code
Инструментарий для автоматической генерации текста программы на языке Си (ANSI C), непосредственно с выделенного фрагмента рабочего файла VisSim. Си код может быть откомпилирован любым компилятором ANSI C для требуемой платформы. Оттранслированная программа может увеличить скорость моделирования более чем в 10 раз. Вторая возможность этого инструментария связана с его совместимостью с VisSim/RealTimePRO расширением, посредствам которого можно настраивать модели, в контур которых включены реальные технические устройства. Например, для настроенной модели регулятора, к которой в процессе отладки был подключен (посредствам платы ввода вывода) двигатель, можно выполнить генерацию кода, откомпилировать его и загрузить в промышленный контроллер, который будет обслуживать двигатель в дальнейшем. Третье направление использования инструментария связано с поставляемой совокупностью файлов, необходимых для создания пользователем своих уникальных моделей на языке Си. Модели пользователя при подключении визуально оформляются как элементарные блоки программы VisSim. Новые блоки можно подключить к меню программы. Используя этот инструментарий можно создавать собственные расширения пакета (Add-Ons) в виде файлов *.dll. Несмотря, на тот факт, что изготовители позаботились только о пользователях компилятора Microsoft Visual C++, предоставляемый интерфейс достаточно прозрачен и позволяет использовать не только другие компиляторы, но и другие языки программирования. Даже в отсутствии этого инструментария можно писать собственные библиотеки (*.dll) и подключать их к пакету (даже к FAP-версии).
VisSim/RealTimePRO
Совокупность программных и аппаратных расширений, посредствам которых можно настраивать модели, в контур которых включены реальные технические устройства. На наносекундный детерминизм рассчитывать не приходится по вине операционной системы Windows, но большинство реальных объектов включать в контур модели можно. Связь с реальными аппаратными средствами осуществляется через стандартные платы ввода/вывода, высокоскоростные специализированные платы для управления движением, последовательный порт, к которому могут быть подключены программируемые логические контроллеры (PLCs) или распределенные системы управления (DCSs). Поддерживается оборудование первого десятка мировых лидеров.
VisSim/ModelWizard
Инструментарий, позволяющий генерировать высокоточные модели для динамических объектов (передаточные функции) на основе измерительной информации получаемой в реальном времени или по историческим данным. Инструментарий содержит совокупность алгоритмов, настроек, которые позволяют идентифицировать сопрягающие частоты даже в присутствии шума и позволяют генерировать модель оптимального или указанного пользователем порядка. Алгоритмы идентификации ориентированы на объекты, поддающиеся линеаризации с одним входом/выходом.
VisSim/DSP
Инструментарий, позволяющий разрабатывать проекты с цифровыми сигнальными процессорами (DSP). Например, для отлаженной модели, в частности для обрабатывающего сигнал фрагмента можно генерировать Си-код, после автоматической компиляции и линковки загрузить программу в сигнальный процессор, выполнить отладку и оптимизацию в интерактивном режиме, используя стандартный инструментарий VisSim-а. Поддержаны сигнальные процессоры фирмы Texas Instruments, как с фиксированной точкой TMS320C62x, так и с плавающей TMS320C67x. Для проектирования регуляторов электропривода поддержано специализированное семейство сигнальных процессоров TMS320C24x. Инструментарий работает с оценочными платами (evaluation boards (EVMs)) TI F243 и TI LF2407 от Texas Instruments.
VisSim/Motion
Совокупность расширений для специалистов в области электропривода. Библиотека специализированных блоков включает более сорока встроенных моделей асинхронных двигателей, машин постоянного тока (безколлекторных), а так же усилителей (силовых драйверов), датчиков, кодеров, динамических нагрузок, контроллеров и блоков сопряжения. Имеется эквивалент библиотеки программ для специализированного семейства сигнальных процессоров TI C2000. А так же инструменты интеграции с пакетами MATLAB, Mathcad и транслятор проектов программы SIMULINK.
VisSim/SigPro
Совокупность алгоритмов для быстрого макетирования приложений, требующих интенсивной обработки сигналов звукового диапазона, речи, измерительной информации, медицинских данных. Инструментарий включает разнообразные источники модулированных и шумовых сигналов, фильтры, операторные и взвешивающие функции. Проектирование фильтров с конечной (FIR) и бесконечной (IIR) импульсными характеристиками упрощено благодаря наличию специального диалогового мастера. Усилены возможности визуализации сигналов.
VisSim/Comm
Библиотека блоков, для моделирования коммуникационных систем во временном домене на сигнальном и системном уровне в полном объеме (от источника до приемника). Библиотека содержит блоки источников сигналов, кодеры, модуляторы, каналы, демодуляторы, декодеры, приемники.

Более подробную информацию о программе VisSim Вы можете найти на сайте фирмы Visual Solutions и на сайте VisSim в России.

3.10.2001


e-Группa "Симуляция движения (моделирование)"

VisSim.nm.ru & VisSim.com

Приглашение к членству в дискуссионной группе
"Симуляция движения" (моделирование)

Уважаемые коллеги, приглашаем Вас вступить в почтовую дискуссионную группу "Симуляция движения". Будучи членом группы вы сможете обратиться с актуальными для вас вопросами к ведущим специалистам России в области моделирования. Сегодня почетными членами группы являются три коллектива разработчиков программ математического моделирования динамических систем:

  • Peter Darnell, президент фирмы Visual Solutions, Inc., которая разрабатывает пакет VisSim и Клиначёв Николай Васильевич, координирующий русскоязычных пользователей пакета VisSim.
  • Козлов Олег Степанович, представитель московского коллектива разработчиков пакета MBTY (Моделирование В Технических Устройствах).
  • Сениченков Юрий Борисович, представитель санкт-петербургского коллектива разработчиков программы MVS (Model Vision Studium).

Дискуссии в группе связаны с аспектами использования специализированных пакетов математического моделирования динамических систем – VisSim, Simulink (MATLAB), SystemBuild (MATRIXx), Anylogic (Model Vision Studium), MBTY, 20-sim, ITI-SIM, DyMoLa, SIMPLORER, DYNAST, hAMSter, Easy5, DASE, Electronics Workbench и т.д. Наиболее активными членами группы являются преподаватели дисциплины "Теория систем автоматического регулирования" и аспиранты соответствующих кафедр. Так же мы рады студентам.

Ключевые слова для обсуждаемых тем: симуляция движения, моделирование, управление; системы (объекты) линейные, нелинейные, непрерывные, дискретные, гибридные; инструменты частотные, корневые, вариационные, нейронные, компилирующие, оценки качества, устойчивости, быстродействия, синтеза, коррекции, оптимизации, линеаризации, программирования цифровых сигнальных процессоров - DSP, отладки в контуре модели реальных объектов.

Дискуссионные группы работают 24 часа в день, 7 дней в неделю, 365 дней в году. Их тысячи. Их работа контролируется почтовыми роботами. Робот – это специальная программа, работающая с почтой на сервере в сети. Именно она обеспечит вам общение с членами группы. Процедура следующая. Вы пишите письмо и направляете его в группу (роботу). Робот проверяет, являетесь ли вы членом группы, и, если это так, то рассылает ваше письмо всем членам. Любой член группы может написать вам ответ. Таким образом, для участия в дискуссиях вам необходимо иметь лишь желание общаться и адрес электронной почты (e-mail).

АДРЕСНАЯ ИНФОРМАЦИЯ ДЛЯ УПРАВЛЕНИЯ ПОДПИСКОЙ (команды почтовому роботу)
Подписка (вступление в группу): vissim-subscribe@yahoogroups.com | пустое письмо
Почтовое сообщение ко всем членам (доступно только члену группы): vissim@yahoogroups.com |
Прекращение членства: vissim-unsubscribe@yahoogroups.com | пустое письмо
Письмо ведущему: vissim-owner@yahoo... |
Приостановка подписки (вы ушли в отпуск): vissim-nomail@yahoogroups.com | пустое письмо
Переход в режим дайджеста (удобен для наблюдателей): vissim-digest@yahoogroups.com | пустое письмо
Возврат в нормальный режим: vissim-normal@yahoogroups.com | пустое письмо
Изменение почтовых настроек: http://groups.yahoo.com/mygroups |
Адрес группы: http://groups.yahoo.com/group/vissim |

Поясним порядок вступления в группу:

  1. Вы посылаете пустое письмо по адресу vissim-subscribe@yahoogroups.com. Его получает робот группы, и, минут через 15, Вы получите его ответ. Поскольку сервис Yahoo является международным, ответ робота будет на английском языке. Суть письма, сформированного для вас роботом, состоит в том, что вам предлагается два способа подтверждения подписки.
  2. Для подтверждения вашего желания подписаться рекомендуется просто отослать письмо робота обратно, воспользовавшись кнопкой "Ответить отправителю" в инструментальной панели почтовой программы (ни каких изменений в письме делать не нужно). Получив ваш ответ, робот включит вас в список членов группы, вышлет вам приветственное сообщение и правила дискуссионной группы (уже на русском языке).
  3. После получения правил дискуссионной группы вы можете приступать к общению с ее членами. Для этого нужно писать письма по адресу vissim@yahoogroups.com.

По адресу группы имеются дополнительные возможности:

  • В архив, доступный членам группы, можно положить свою интересную модель.
  • Вы найдете коллекцию интересных нашей группе ссылок и внесете свои.
  • Можете инициировать голосование и принять в нем участие.
  • Можете обсудить вопросы в тематическом web-форуме.
  • Составить краткую справку о себе для членов группы.
  • Настроить способ получения почты.

Если сейчас у вас нет возможности отправить письмо (т.е. вы за чужим компьютером) – воспользуйтесь желтой формой, которая приведена ниже.

Online подписка на VisSim
Сервис groups.yahoo.com

PS Более 650 российских специалистов в области АСУ ТП уже выбрали подобный инструмент общения (asutp-subscribe@yahoogroups.com), оценив этот сервис выше услуг серверов новостей (группа news:fido7.ru.scada SCADA - системы автоматизации). Есть группа, обсуждающая вопросы использования в России программной и аппаратной продукции корпорации National Instruments (LabVIEW_ru-subscribe@yahoogroups.com).

19.10.2000


e-Группa "LabVIEW и цифровая обработка сигналов"

LabVIEW

Приглашение к членству в дискуссионной группе
"Цифровая обработка сигналов и LabVIEW"

Уважаемые коллеги, приглашаем вас в почтовую дискуссионную группу (форум-рассылка), которая не требует подключения к серверу новостей. Необходимо иметь только почтовый адрес (e-mail). Можно и подписаться по почте. Ваши сообщения будут получать все члены группы.

Мы приветствуем обсуждение вопросов использования в России программной и аппаратной продукции корпорации National Instruments. Ключевые слова: алгоритмы измерительные, дискретизация, квантование, обработка сигналов, интерполяция, функции окон, ДПФ, БПФ, КИХ БИХ фильтры, (FFT, FIR, IIF), датчики измерительные, метрология, программирование графическое (G-язык), LabVIEW, TestStand, ComponentWorks, Measurement Studio, IMAQ, HiQ, SCXI, PXI, GPIB, VXI, VME, Lookout, BridgeVIEW, OPC, SCADA. Приглашаем присоединяться к нам. Для чего вам потребуются адреса (или форма внизу страницы):

АДРЕСНАЯ ИНФОРМАЦИЯ ДЛЯ УПРАВЛЕНИЯ ПОДПИСКОЙ
Подписка (вступление в группу): LabVIEW_ru-subscribe@yahoogroups.com | пустое письмо
Почтовое сообщение ко всем членам (доступно только члену группы): LabVIEW_ru@yahoogroups.com |
Прекращение членства: LabVIEW_ru-unsubscribe@yahoogroups.com | пустое письмо
Письмо ведущему: LabVIEW_ru-owner@yahoogroups.com |
Приостановка подписки (вы ушли в отпуск): LabVIEW_ru-nomail@yahoogroups.com | пустое письмо
Переход в режим дайджеста (удобен для наблюдателей): LabVIEW_ru-digest@yahoogroups.com | пустое письмо
Возврат в нормальный режим: LabVIEW_ru-normal@yahoogroups.com | пустое письмо
Изменение почтовых настроек: http://groups.yahoo.com/mygroups |
Адрес группы: http://groups.yahoo.com/group/LabVIEW_ru |

Ели для подписки вы используете почту, то обратите внимание, что вам будет прислано письмо на английском языке, с просьбой подтвердить подписку. Его достаточно просто вернуть адресату. Это подтвердит ваше согласие.

По адресу группы имеются дополнительные возможности:

  • В архив доступный членам группы можно положить свой рабочий файл, статью.
  • Вы найдете коллекцию интересных нашей группе ссылок и внесете свои.
  • Можете инициировать голосование и принять в нем участие.
  • Можете обсудить вопросы в тематическом web-форуме.
  • Составить краткую справку о себе для членов группы.
  • Настроить способ получения почты.
Сегодня в группе вы можете общаться со специалистами компании "ИнСис Лтд", которая является единственным официальным дистрибьютором и системным интегратором NI в России. В дискуссии принимают участие и русскоязычные работники корпорации NI. Подписка на LabVIEW_ru
Сервис groups.yahoo.com

Более 600 российских специалистов в области АСУ ТП уже выбрали этот инструмент общения (asutp-subscribe@yahoogroups.com), оценив этот сервис выше услуг серверов новостей (группа news:fido7.ru.scada SCADA - системы автоматизации).

28.03.2001


2 Введение в моделирование и в VisSim

Советы

Для того чтобы эффективно освоить и выполнить лабораторные работы по ТАУ, целесообразно при подготовке к работе оформить бланк отчета с титульным листом, куда занести цель и задачи работы, а также очень кратко теоретические сведения. Выполняя работу, полезно вначале прочитать отдельный раздел задания методических указаний, развернув их окно на полный экран. Затем выполнять требуемые действия, расположив в верхней части экрана окно программы VisSim, а в нижней части – окно методических указаний с некоторым их перекрытием, что упростит переход из одного окна к другому (см. рис. 2.1).

Методические указания рассчитаны на студентов среднего уровня и слабых студентов, а также на студентов-заочников. Поэтому изложение проведено обстоятельно, что может раздражать сильных, но не усидчивых студентов. Таковым можно порекомендовать после ознакомления с теорией, выполнять диаграммы по их рисункам, представленным в окончательном виде, а при возникновении затруднений обращаться к указаниям.

Задание к л.р. №1 > Методические указания

1. Краткие сведения о структурно-объектном моделировании и о программном комплексе VisSim

  • 1.1. Назначение программы VisSim
  • 1.2. Графический интерфейс VisSim
  • 1.3. Принципы построения моделей в среде VisSim
  • 1.4. Основные блоки VisSim
  • 1.5. Принципы управления моделью и получения результатов моделирования
  • 1.6. Понятие о принципах функционирования программы VisSim
  • 1.7. Версии VisSim

Понятие «модель» весьма широкое и многозначное. Можно утверждать, что человек, часто не думая об этом, в жизни все время создает и использует всевозможные модели: окружающего пространства, поведения других людей, физических и технических объектов и т.д., с тем, чтобы получить практическую пользу. Можно сказать, что отображение реальности сознанием человека является в той или иной степени моделированием. Например, переходя дорогу, мы моделируем движение приближающейся машины, чтобы предсказать, успеем ли безопасно перейти, и выбрать правильное решение.

В науке и технике модели могут быть:

  • физическими (масштабными и аналоговыми),
  • математическими (аналитическими),
  • виртуальными (воображаемыми, реализуемыми на компьютерах) и др.

Моделирование технических объектов и систем проводится для того, чтобы определить свойства и характеристики проектируемых систем еще до их изготовления и при необходимости скорректировать, уточнить их структуру и параметры. Это позволяет получить проект работоспособной системы, которую не придется существенно дорабатывать тогда, когда она будет изготовлена. Таким образом, моделирование сокращает и удешевляет процесс проектирования и реализации систем и объектов.

Кроме того, на модели системы можно проверить ее поведение в таких условиях и режимах, для которых система не предназначена, с тем, чтобы знать, как она себя поведет и к каким последствиям это приведет. Очевидно, что такие эксперименты на реальной системе могут быть не только дороги, но и небезопасны, в то время как моделирование позволяет получить нужную информацию о процессе или системе без лишних затрат и, главное, без негативных последствий.

Задание к л.р. №1 > Методические указания

1.1. Назначение программы VisSim

Программа VisSim предназначена для построения, исследования и оптимизации виртуальных моделей физических и технических объектов, в том числе и систем управления. VisSim это аббревиатура выражения Visual Simulator – визуальная, воспринимаемая зрением, среда и средство моделирования.

Программа VisSim, разработана и развивается компанией Visual Solutions (USA) [1]. Эта программа – мощное, удобное в использовании, компактное и эффективное средство моделирования физических и технических объектов, систем и их элементов.

Программа предоставляет человеку развитой графический интерфейс, используя который, исследователь создает модель из виртуальных элементов с некоторой степенью условности так же, как если бы он строил реальную систему из настоящих элементов. Это позволяет создавать, а затем исследовать и оптимизировать модели систем широкого диапазона сложности.

При описании и последующем построении модели в среде VisSim нет необходимости записывать и решать дифференциальные уравнения, программа это сделает сама по предложенной ей исследователем структуре системы и параметрам ее элементов. Результаты решения выводятся в наглядной графической форме. Поэтому программой могут пользоваться и те, кто не имеет глубоких познаний в математике и программировании.

При использовании VisSim'а не требуется владеть программированием на языках высокого уровня или ассемблере. В то же время, специалисты, владеющие программированием, могут создавать собственные блоки, дополняя ими богатую библиотеку стандартных блоков VisSim'а.

Моделирование систем управления это далеко не весь круг задач, которые можно решать в VisSim. Например, в этой программе при желании можно решать дифференциальные уравнения и VisSim делает это значительно эффективнее и быстрее, чем известная программа математической направленности MathCAD. При соизмеримой и более высокой производительности, чем у программы Simulink, входящей в солидный программный пакет MathLab, VisSim занимает в сотни раз меньше места на жестком диске и в оперативной памяти.

VisSim позволяет также решать задачки по физике, начиная с уровня школьных и кончая серьезными физическими экспериментами на виртуальных лабораторных стендах.

Рис. 1.1 (анимация 29 кадров). Воспроизведение анимации, созданной в программе VisSim для иллюстрации решения задачи о полете пушечного ядра с учетом сопротивления воздуха. Траектория полета ядра подчиняется соотвествующим уравнениям, которые решает VisSim. Из графиков траекторий видно, что существенное изменение угла наклона ствола пушки с 20° до 30° приводит к незначительному изменению дальности полета снаряда (если изображение не меняется, щелкните левой кнопкой мыши по рисунку).

Решение задачи о полете пушечного ядра с учетом сопротивления воздуха осуществляется моделью, созданной в VisSim'е:

Рис. 1.2. Наполнение составного блока Calculation of a trajectory (рис. 1.1), осуществляющего вычисление траектории полета ядра и отображение ее и других переменных величин. VisSim позволяет всесторонне изучить поведение модели.

Российским аналогом программы VisSim является программный комплекс "МВТУ" [2].

Задание к л.р. №1 > Методические указания

1.2. Графический интерфейс VisSim

Интерфейс программы это совокупность средств, позволяющих человеку общаться с ней:

  • вводить и получать данные,
  • контролировать ход выполнения компьютером программы,
  • подавать управляющие воздействия и наблюдать реакцию на них программы и т.п.

Программа VisSim предоставляет исследователю графический интерфейс, позволяющий основную часть работы по созданию модели выполнить с помощью мыши, а параметры элементов ввести с клавиатуры. Интерфейс VisSim состоит из главного окна, имеющего меню и ряд кнопок управления, воспринимающих щелчки копок мыши, и т.н. рабочего пространства, в котором строится и корректируется модель, наблюдаются результаты ее работы (рис. 1.3).

С точки зрения исследователя интерфейс программы VisSim представляет собой интерактивный виртуальный лабораторный стенд, обеспечивающий построение моделей из отдельных блоков, запуск процесса моделирования, управление им и контроль результатов.

Главное окно VisSim, с примером простой диаграммы имеет вид рис. 1.3.

Рис. 1.3. Главное окно программы VisSim и ее рабочее пространство с примером простой VisSim-диаграммы (модели и надписей). На рабочее пространство вынесены виртуальные блоки: генератор и осциллограф, а также надписи. При запуске процесса моделирования (щелчком по кнопке с зеленым треугольником [image] Пуск - Go), на осциллографе изображается сигнал, вырабатываемый генератором, в данном случае - синусоида. Амплитуду, частоту и начальную фазу сигнала генератора исследователь может менять, и при новом запуске моделирования эти изменения будут приводить к соответствующему изменению графика на экране осциллографа. В верхней части окна отображается название диаграммы

Меню VisSim позволяет выполнять, наряду с другими, следующие важные действия:

  • File (работа с файлами) – открывать новую диаграмму, сохранять, а затем при необходимости вновь открывать созданную диаграмму.
  • Edit (Редактирование) - разворачивать на 180 градусов отдельные, выделенные блоки, а также создавать составные (Compound) блоки и отменять последние изменения, внесенные в диаграмму.
  • Simulate (Моделировать) – запускать процесс моделирования и изменять важные параметры этого процесса: время работы модели и величину шага интегрирования.
  • Blocks (Блоки) – выносить на рабочее пространство элементарные блоки, из которых составляется модель, и надписи.
  • Analyze (Анализировать) – строить частотные характеристики выделенных фрагментов линейной части модели.
  • View (Вид) – устанавливать шрифт надписей и красивый вид блоков (Presentation Mode).
  • Help (Помощь, справка) – получать справочный материал по программе и отдельным ее блокам.

Диаграммой в VisSim'е называется совокупность связанных, а также автономных блоков и надписей, помещенных на рабочее пространство и способных в известном смысле функционировать при запуске процесса моделирования. Диаграмма может быть сохранена в виде отдельного файла и, при необходимости, открыта вновь.

Модель VisSim’а это часть диаграммы, содержащая виртуальный аналог реальной или проектируемой системы. Диаграмма может содержать несколько моделей.

К модели VisSim'а в принципе могут быть подключены, с помощью дополнительных компьютерных плат, и внешние физические устройства, которыми модель системы, построенная в VisSim’е, сможет управлять. Таким образом, объектами управления модели системы автоматического управления, построенной в VisSim, могут быть не только виртуальные, но и реальные устройства.

Задание к л.р. №1 > Методические указания

1.3. Принципы построения моделей в среде VisSim

Исходными данными для построения модели в VisSim’е являются структурно-функциональная схема моделируемой системы, процесса или объекта и описывающие их дифференциально-алгебраические уравнения. Вместо таких уравнений могут быть заданы операторы или функции, характеризующие отдельные элементы моделируемой системы, например, передаточнные функции для линейных элементов и статические характеристики для нелинейных элементов.

Рис. 1.4. Исходная функциональная схема САР частоты вращения вала двигателя постоянного тока и ее структурно-алгоритмическая модель

Реальные системы и объекты состоят из отдельных, связанных и взаимодействующих друг с другом элементов. И для всей системы в целом, и для отдельных ее, должным образом выбранных элементов, можно указать место приложения воздействия, которое можно назвать входом, и место их реакции (отклика) на входное воздействие, называемое выходом. И воздействие, и реакция это некоторые физические величины, являющиеся функциями времени.

Модели систем и объектов в программе VisSim строятся из отдельных элементов – т.н. блоков. Блок это виртуальный аналог физического элемента реальной системы. «Виртуальный» в данном контексте значит воображаемый, физически не существующий, реализуемый программно, но с точки зрения человека, работающего с моделирующей программой, блок воспринимается зрением, он видим на рабочем пространстве VisSim. Термин «аналог» предполагает, что блок функционирует, он подчиняется тем же самым уравнениям, что и реальный, моделируемый элемент системы.

Виртуальные блоки VisSim’а могут иметь или вход, на который может быть подан выходной сигнал другого блока, или выход, виртуальный сигнал с которого может быть подан на вход другого блока. Наконец, блоки могут иметь и вход, и выход одновременно. Взаимодействие между блоками отображается т.н. линиями связи, указывающими направление передачи воздействий (сигналов) от одного блока к другому.

Взаимодействие между блоками моделируется сигналами – функциями времени, передаваемыми между блоками по линиям связи. Сигналы в модели могут быть измерены с помощью виртуальных измерительных устройств или рассмотрены и изучены с помощью виртуального осциллографа.

Внешне виртуальные блоки VisSim с некоторой степенью условности воспринимаются исследователем так же, как реальные устройства. Например, генераторы вырабатывают сигналы, блоки-преобразователи реагируют на входные сигналы в определенном смысле точно так же, как реальные устройства на реальные воздействия, индикаторы показывают величины сигналов.

Рис. 1.5. (анимация 25 кадров). Пример последовательности действий при вынесении на рабочее пространство и перемещении блока надписи программы VisSim. Красные кружки вокруг курсора условно обозначают щелчки левой кнопкой мыши. Для запуска анимации, если рисунок не изменяется, следует щелкнуть по кнопке «Обновить» в верхней части браузера (окна, в котором вы читаете этот текст) или просто по рисунку. Для остановки некоторого кадра, чтобы его подробнее рассмотреть, следует щелкнуть в нужный момент по кнопке «Стоп» браузера

Т.о. принцип построения модели в VisSim’е состоит в вынесении на рабочее пространство моделей реальных элементов (блоков) и соединении их в соответствии с заранее составленной структурно-алгоритмической схемой моделируемой системы. Такое построение модели из виртуальных блоков очень похоже, с известной степенью условности, на построение реальной системы из настоящих блоков (генераторов, осциллографов, и других устройств) в производственных условиях или на лабораторном стенде.

Задание к л.р. №1 > Методические указания

1.4. Основные блоки VisSim

Элементарные блоки VisSim’а можно условно разделить на три основных категории и одну дополнительную:

  • Блоки, имеющие только выход: генераторы.
  • Блоки, имеющие вход и выход: преобразователи.
  • Блоки, имеющие только вход: индикаторы.
    • Осциллограф
    • Цифровой индикатор
  • Блоки без входов и выходов: надписи, комментарии и др.

Для удобства работы с диаграммой, часть ее блоков, в частности, часть блоков модели, можно заключить в один составной, т.н. Compound Block. Это позволяет создавать модели иерархической структуры очень сложных систем и объектов. Такие блоки могут иметь не только вход и (или) выход, но и множество входов и (или) выходов или не иметь их вообще.

Важным компонентом модели является соединительная линия – виртуальный аналог физического соединения элементов, передающего воздействия от одного элемента к другому. Соединительные линии в VisSim’е однонаправленные, передают сигналы с выхода одного блока к входу другого. Поэтому при построении модели следует так разделять реальную систему на функциональные блоки, чтобы последующий блок практически не влиял на функционирование предыдущего. Например, выходное электрическое сопротивление предыдущего блока должно быть значительно меньше входного сопротивления последующего блока.

Примечание: Входные и выходные сигналы могут быть как одиночными функциями времени, так и набором таких функций. В последнем случае сигнал называется векторным, как и соответствующий вход или выход блока.

Задание к л.р. №1 > Методические указания

1.4.1. Генераторы

Генераторы это блоки, имеющие только выход.

Генераторы вырабатывают изменяющиеся во времени или постоянные сигналы.

Примерами таких блоков в VisSim являются блоки:

  • step (ступенька) [image] – генератор ступенчатой единичной функции 10(t);
  • ramp (спуск, подъем) [image] – генератор линейно растущего сигнала t·10(t);
  • sinusoid [image] – генератор синусоидального сигнала Amsin(ωt+φ);
  • const [image] – генератор постоянного сигнала, величина которого не меняется в процессе работы модели;
  • slider (скользящий контакт, ползунок) [image] – генератор постоянного сигнала, величину которого можно менять в процессе работы модели.

Рис. 1.6. Важные блоки-генераторы программы VisSim. Для помещения блока на рабочее пространство следует щелкнуть по пункту меню Blocks, перейти на пункт Signal Producer, затем щелкнуть по названию требуемого генератора, перевести курсор в нужное место рабочего пространства и щелкнуть левой кнопкой мыши

Задание к л.р. №1 > Методические указания

1.4.2. Преобразователи

Преобразователи это блоки, имеющие входы и выходы.

Блоки-преобразователи способны воспринимать воздействия от других блоков, преобразовывать их в соответствии с определенными уравнениями или правилами и выдавать преобразованный сигнал (отклик, реакцию блока) на выход.

Важнейшие блоки для моделирования линейных систем:

  • блок transferFunction [image] – передаточная функция. Этот блок позволяет создавать модели как простых, так и очень сложных элементов линейных систем и систем в целом;
  • integrator [image] – блок интегратора, осуществляющий интегрирование входного сигнала по времени и являющийся фундаментальным кирпичиком любой линейной модели системы или объекта;
  • summingJunction [image] – сумматор двух и более сигналов, его выходной сигнал равен алгебраической сумме входных.
  • gain [image] – усилитель.

Рис. 1.7. Меню для вызова блока передаточная функция (transferFunction). Сумматор и усилитель вызываются путем выбора: Blocks → Arithmetic → summingJunction или gain (усилитель)

Задание к л.р. №1 > Методические указания

1.4.3. Индикаторы

Индикаторы это блоки, имеющие только вход.

Индикаторы программы VisSim предназначены для отображения сигналов в форме удобной и привычной для исследователя.

Важнейшими индикаторами являются блоки:

  • осциллограф – plot; [image] Осциллограф представляет в наглядном виде зависимости величины сигналов от времени.
  • цифровой индикатор – display [image]. Этот индикатор показывает в цифровой форме значение постоянного сигнала, подаваемого на него.

Рис. 1.8. Меню для вызова блоков plot (осциллограф), display (цифровой индикатор) и meter (стрелочный прибор) – важнейших виртуальных измерительных приборов программы VisSim

Задание к л.р. №1 > Методические указания

Осциллограф

Как показывает практика, не все студенты представляют себе назначение и принципы работы и использования реального, настоящего осциллографа. Поэтому кратко сообщим об этом.

Осциллограф предназначен для графического представления в течение некоторого временного интервала зависимости мгновенной величины исследуемого сигнала от времени.

Рис. 1.9. Внешний вид осциллографа С1-157. Ниже экрана ЭЛТ расположены входные разъемы, куда подаются исследуемые сигналы

Основа осциллографа – электронная лучевая трубка ЭЛТ. Она имеет экран, на котором луч электронной пушки ЭЛТ высвечивает маленькое пятно. Трубка имеет отклоняющие луч системы, одна из которых, горизонтально-отклоняющая, равномерно перемещает луч, а, следовательно, и пятно, по экрану слева направо. Поэтому в течение времени развертки положение пятна на экране по горизонтальной оси пропорционально времени. Это способ представить, развернуть время в пространстве.

На другую, отклоняющую луч по вертикали систему ЭЛТ, подается исследуемый, меняющийся во времени сигнал. Отклоняющая система ЭЛТ устроена так, что отклонение луча по вертикали пропорционально мгновенному значению исследуемого сигнала.

Таким образом, луч, а, следовательно, и пятно на экране, участвуют одновременно в двух движениях: равномерном по горизонтали и, в соответствии с изменением величины сигнала во времени, по вертикали. В результате, на экране получается изображение зависимости сигнала от времени. Продолжительность временного отрезка, в течение которого наблюдается сигнал, называется временем развертки. Осциллографы позволяют наблюдать периодические сигналы, в этом случае используется периодическая развертка, частота которой подбирается в целое число раз меньшей, чем частота исследуемого сигнала. При наблюдении непериодических сигналов луч пробегает по экрану слева направо один раз, а трубка выбирается с длительным послесвечением люминофора.

Рис. 1.10. Осциллограф развертывает на экране зависимость мгновенной величины сигнала от времени

Виртуальный осциллограф VisSim’а представляет собой окно, похожее на экран осциллографа, в котором изображается зависимость наблюдаемых сигналов от времени (рис. 1.10). На боковой стороне осциллографа помещены условные изображения входов, к которым могут быть подключены выходы других блоков диаграммы для наблюдения поведения их сигналов в зависимости от времени.

Цифровой индикатор

Цифровой индикатор display VisSim’а – выводит, показывает в цифровом виде значение сигнала на выходе того блока, к которому он подключен. Этот прибор используется для измерения постоянных величин.

Задание к л.р. №1 > Методические указания

1.4.4. Надписи и комментарии

Надписи это блоки без входов и выходов.

Эти блоки позволяют создавать на рабочем пространстве диаграммы VisSim текстовые области, которые помогают понять смысл диаграммы и содержат сведения о том, кто, когда и какую диаграмму создал. Основной блок: label – надпись.

Задание к л.р. №1 > Методические указания

1.5. Принципы управления моделью и получения результатов моделирования

Построенную модель следует запустить в работу, щелкнув по кнопке с зеленым треугольником [image] "Пуск" (рис. 1.3 и 1.5). В результате работы модели выходные сигналы блоков начнут изменяться, их величины просматривают на виртуальном осциллографе и других индикаторах. Параметры некоторых сигналов и блоков исследователь может изменять в процессе работы модели, другие параметры можно изменить, остановив процесс работы модели. Продолжительность работы модели можно задавать до ее запуска, можно и прерывать работу модели по желанию исследователя.

Задание к л.р. №1 > Методические указания

1.6. Понятие о принципах функционирования программы VisSim

После того, как модель построена, когда на рабочее пространство вынесены и соединены в нужном порядке блоки, составляющие систему, генераторы сигналов и индикаторы, а также введены параметры элементов модели, может быть запущен процесс ее функционирования. Для этого следует щелкнуть по кнопке с зеленым треугольником [image] "Пуск" (рис. 1.3 и 1.5).

Получив эту команду, программа начинает анализировать то, как соединены блоки, на основе этого анализа составляет дифференциально-алгебраические уравнения, описывающие модель и решает их. Полученные результаты, как функции модельного времени, периодически и очень часто, придаются значениям входных и выходных сигналов блоков. Эта способность программы выполнять столь сложные, интеллектуальные действия, удивляет и восхищает.

Дифференциально-алгебраические уравнения математически описывают т.н. динамические объекты, объекты очень широкого класса, обладающие инерционностью и рядом других свойств. И поскольку программа VisSim способна решать такие уравнения, то в ней можно моделировать системы и объекты очень широкого диапазона сложности.

Решение уравнений проводится по шагам – дается малое приращение времени, вычисляются, с учетом начальных условий, значения сигналов на выходах и входах всех блоков, затем вновь дается малое приращение времени, проводятся вычисления и т.д. Малая величина шага интегрирования позволяет исследователю воспринимать сигналы как непрерывные. Выходные сигналы любого блока при желании можно наблюдать на экране виртуального осциллографа или измерять виртуальным цифровым индикатором. В результате решения можно получить зависимости выходных сигналов от времени. Таким образом, работа по моделированию систем в программе VisSim для исследователя похожа на работу на реальном стенде.

Кроме того, программа позволяет более глубоко проанализировать полученные результаты и оптимизировать модель. Например VisSim предоставляет возможность быстрого построения частотных характеристик фрагментов модели и всей системы.

Задание к л.р. №1 > Методические указания

1.7. Версии VisSim

В настоящее время доступны следующие версии VisSim [1]:

  • Академическая версия 3.0 - для некоторых Вузов поставляется фирмой Visual Solution Inc. бесплатно [1]. Имеет некоторые ограничения и предназначена для использования в учебных, некоммерческих целях.
  • Студенческая версия – доступна бесплатно [3].
  • Версия 5 - возможности расширены, но бесплатно доступен только ознакомительный вариант [1].
  • Ознакомительная русифицированная версия [4]. Выпущен только пилотный вариант, который может потребовать доработки, поэтому на сегодня предпочтительнее пользоваться академической версией на английском языке.


3 Запуск VisSim, надписи

Задание к л.р. №1 > Методические указания

2.1. Запуск программы VisSim

С разрешения преподавателя запустить программу VisSim двойным щелчком по файлу vissim32.exe. Если программа была установлена по умолчанию, то этот файл находится в папке по адресу C:\VisSim_FAP30\VisSim30. В противном случае, следует спросить у преподавателя, где находится этот файл или щелкнуть дважды по ярлыку программы VisSim, при его наличии на рабочем столе.

Окна программы и настоящих методических указаний целесообразно расположить одно над другим, примерно вот так:

Рис. 2.1. Расположение окон программы VisSim (вверху) и методических указаний (в нижней половине), упрощающее переход от одного окна к другому

При необходимости каждое из окон можно развернуть на весь экран. Выполняя работу, полезно вначале прочитать отдельный раздел задания методических указаний, развернув их окно на полный экран. Это позволит помнить и чувствовать цель и задачи раздела, охватить его в общем. Затем можно выполнять требуемые действия, расположив в верхней части экрана окно программы VisSim, а в нижней части – окно методических указаний с некоторым перекрытием, что упростит переход из одного окна к другому (см. рис. 2.1).

Выбрать в меню VisSim’а: View (Вид) и проверить наличие галочки у пункта Presentation Mode (Способ Представления). Если ее нет, то щелчком левой кнопки установить. В этом режиме изображения блоков на рабочем пространстве более красивые.

Задание к л.р. №1 > Методические указания


32 Надписи

Задание к л.р. №1 > Методические указания

2.2. Помещение на рабочее пространство и редактирование надписей

  • 2.2.1. Задание шрифта
  • 2.2.2. Первая надпись
  • 2.2.3. Сопроводительная надпись диаграммы

2.2.1. Задание шрифта

Для обеспечения возможности помещения на рабочем пространстве надписей на русском языке установить – Кириллицу: выбрать в меню View (Вид) ® Fonts (Шрифты). Появляется окно диалога, в котором полезно установить шрифт MS Sans Serif, а его размер сделать равным 8. Удостовериться, что набор символов кириллический и закрыть окно, щелкнув по кнопке ОК.

Примечание. В принципе можно установить и другие шрифты, но тогда при новом открытии сохраненной диаграммы, надписи будут выполнены нечитаемым шрифтом, который придется каждый раз менять на кириллицу.

Рис. 2.2. Задание русского шрифта диаграммы VisSim

2.2.2. Создание первой надписи

Создать надпись "Привет, Студент! Hi, Student!": Для этого в меню выбрать Blocks (Блоки) ® Annotation (Пояснения) ® Label (Надпись), щелкнув левой кнопкой мыши по последнему пункту. Переместить курсор, с «прикрепившимся» к нему пунктирным прямоугольником, в нужное место рабочего пространства и щелчком левой кнопки мыши зафиксировать положение блока надписи. На рабочем пространстве появится надпись label. При необходимости надпись, как и любой другой блок можно перемещать по рабочему пространству, схватывая левой кнопкой и отпуская на новом месте.

Рис. 2.3 (анимация 20 кадров). Помещение блока надписи на рабочее пространство. Красные кружки отображают момент нажатия левой кнопки мыши. Для остановки анимации, если требуется подробнее рассмотреть отдельный кадр, следует щелкнуть по кнопке "Остановить" в верхней части браузера (окна, в котором вы читаете этот текст). Для запуска анимации нужно щелкнуть по кнопке "Обновить" или просто по рисунку

Щелкнуть правой кнопкой мыши (или дважды левой) по надписи label на рабочем столе. В появившемся окне ввести требуемую надпись. Для перехода на новую строку следует, удерживая нажатой клавишу Ctrl (Control - Управление), нажать клавишу Enter (Ввод). При необходимости установить шрифт надписи: щелкнуть правой кнопкой на надписи ® Font ® Кириллица и MS Sans Serif.

Щелкнуть по кнопке ОК.

Рис. 2.4 (анимация 24 кадра). Введение текста надписи. Для переноса текста на новую строку следует, удерживая нажатой клавишу Ctrl, нажать клавишу Enter (Ctrl + Enter)

По желанию установить другой размер и вид шрифта, цвет заднего плана надписи. Поэкспериментировать со шрифтами и цветами. Вернуть исходные значения характеристик шрифта: View (Вид) ® Fonts (Шрифты), MS Sans Serif, кириллица, размер 8.

Текст надписи можно редактировать неоднократно в любое время.

Задание к л.р. №1 > Методические указания

2.2.3. Создание сопроводительной надписи диаграммы

Создать надпись, в которой указать сведения о диаграмме и о том, кто, когда и где ее выполнил.

Рис. 2.5. Ввод в диаграмму сопроводительного текста. Для переноса текста на новую строку следует, удерживая нажатой клавишу Ctrl, нажать клавишу Enter (Ctrl + Enter)

Щелкнуть по кнопке ОК. Переместить сопроводительную надпись на нужное место.

Рис. 2.6. Примерное содержание сопроводительной надписи

Т.о. надписи сделаны.

Задание к л.р. №1 > Методические указания


4 Исследование первого стенда

2.3. Создание, настройка и испытание простого виртуального лабораторного стенда

  • 2.3.1. Помещение блоков на рабочее пространство VisSim
  • 2.3.2. Соединение блоков
  • 2.3.3. Запуск процесса моделирования
  • 2.3.4. Сохранение диаграммы
  • 2.3.5. Управление генератором
  • 2.3.6. Управление осциллографом
  • 2.3.7. Первая модель

Первая модель лабораторного стенда будет состоять всего лишь из виртуального генератора синусоидального напряжения и подключенного к нему виртуального осциллографа, на экране которого будет воспроизводиться, и наблюдаться сигнал генератора. Это позволит частично убедиться в работоспособности программы VisSim, т.е. в том, что виртуальные приборы действительно воспринимаются исследователем и работают так же, как и их реальные аналоги.

Законченная диаграмма будет иметь примерно вот такой вид:

Рис. Первая диаграмма в законченном виде. Она содержит три генератора, осциллограф и четыре надписи

Задание к л.р. №1 > Методические указания

2.3.1. Помещение блоков на рабочее пространство VisSim

Поместить на рабочий стол генератор синусоиды (sinusoid) и осциллограф (plot).

Для этого в меню программы выбрать Blocks (Блоки) ® Signal Producer (Генераторы сигналов) ® sinusoid (генератор синусоидального сигнала), поместить генератор в нужное место рабочего стола, в верхней его левой части, а затем выбрать Blocks ® Signal Consumer (Индикаторы сигналов) ® plot (осциллограф, график) и поместить осциллограф правее генератора (рис 2.7).

Рис. 2.7. Предварительное размещение блоков генератора и осциллографа на рабочем пространстве. Отметим, что в начале, по умолчанию частота синусоидального сигнала генератора равна F = 1 рад/сек, а амплитуда A = 1 условных единиц. Далее частоту, амплитуду и начальную фазу генератора можно будет изменить

Задание к л.р. №1 > Методические указания

2.3.2. Подключение генератора к осциллографу

Подключить генератор синусоиды к осциллографу: нажав у выхода генератора, когда курсор примет вид вертикальной стрелки, и удерживая левую кнопку мыши, подтянуть соединительную линию к входу осциллографа и отпустить кнопку (рис. 2.8). Повторим, что линия создается, если в момент нажатия кнопки мыши курсор установлен вблизи выхода блока так, что приобретает вид вертикальной стрелки. Для разрыва соединения нужно левой кнопкой мыши ухватить входное соединение, отнести в сторону и бросить (рис. 2.9).

Рис. 2.8 (анимация 17 кадров). Соединение блоков. Красные кружки отображают момент нажатия левой кнопки мыши. Для остановки анимации, если требуется подробнее рассмотреть отдельный кадр, следует щелкнуть по кнопке "Остановить" в верхней части браузера (окна, в котором вы читаете этот текст). Для запуска анимации нужно щелкнуть по кнопке "Обновить" или просто по рисунку

Примечание. На первых порах студенты часто допускают ошибку в соединении блоков, придвигая один блок вплотную к другому. Внешне это выглядит так, как-будто выход первого блока соединен с входом второго. Но на самом деле, поскольку линия связи между блоками не проведена, то и передачи сигнала с выхода одного блока на вход другого не происходит и модель или не работает вовсе, или работает не правильно. Это можно сравнить со случаем, когда реальные электрические устройства соединяются проводами без зачистки изоляции. По такому соединению ток не потечет.

Таким образом, целесообразно вначале разнести соединяемые блоки на заметное расстояние, соединить их линией связи, а потом, при необходимости, придвинуть их ближе друг к другу.

Рис. 2.9 (анимация 14 кадров). Разрыв связи между блоками

Модель построена.

Задание к л.р. №1 > Методические указания

2.3.3. Приведение модели в действие

Запустить программу на выполнение: щелчком по кнопке [image] с зеленым треугольником или выбрать в меню Simulate ® Go (Моделировать - Пуск). На осциллографе появится график начальной части синусоиды, а оси автоматически приобретут градуировку:

Рис. 2.10. Простейший виртуальный лабораторный стенд, состоящий из генератора синусоидального сигнала и подключенного к нему осциллографа, после окончания процесса моделирования. За время моделирования - одну секунду программе удается воспроизвести, а наблюдателю затем увидеть на осциллографе только начальную часть синусоиды – выходного сигнала генератора, т.к. период его синусоиды равен T = 2p/F = 2p/1 = 6.28 сек

Задание к л.р. №1 > Методические указания

2.3.4. Сохранение исходной диаграммы

По мере создания модели полезно сохранять промежуточные результаты, с тем, чтобы в случае ошибок или зависания программы, что впрочем, случается чрезвычайно редко, не выполнять всю работу заново, начиная с нуля.

В меню File (Файл) программы VisSim выбрать Save As (Сохранить как), в появившемся диалоговом окне указать путь к личной папке, создать в ней папку TAU_Lab1, войти в нее, задать содержательное название файла диаграммы, например Lab1_1_Gen_sin.vsm и сохранить. Подробно порядок сохранения файла приведен в [5]. Посмотреть в папку с названием TAU_Lab1 и убедиться, что сохраненный файл находится именно в ней.

Задание к л.р. №1 > Методические указания

2.3.5. Управление виртуальным генератором

Перед тем, как вносить изменения в модель и диаграмму в целом, целесообразно сохранить ее в папке первой лабораторной работы под новым именем Lab1_2_Gen_sin.vsm. Теперь изменения будут сохраняться в модели с этим названием, а предыдущая диаграмма, Lab1_1_Gen_sin.vsm останется неизменной и всегда может быть при необходимости открыта из личной папки.

В настоящем, реальном генераторе на физическом стенде исследователь может менять амплитуду, частоту и начальную фазу синусоиды с помощью кнопок и ручек управления, расположенных на лицевой панели. Это же позволяет сделать и виртуальный генератор VisSim’а, но в специальном диалоговом окне.

Дважды левой (или один раз правой) кнопкой мыши щелкнуть по блоку генератора синусоиды (sinusoid), в появившемся окне

Рис. 2.11. Задание параметров выходного сигнала генератора установить частоту (Frequency) 12 рад/сек, амплитуду (Amplitude) 2.3, начальную задержку синусоиды (Delay) 0. Отметим, что в качестве десятичного знака следует ставить точку, а не запятую

Щелкнуть по кнопке ОК.

Запустить модель кнопкой [image] "Пуск". Убедиться, что частота синусоиды, воспроизведенной на осциллографе, увеличилась.

Задание к л.р. №1 > Методические указания

2.3.6. Управление виртуальным осциллографом

Поменять настройки осциллографа (plot'а). Это улучшит восприятие графика (рис. 2.13). Для этого

  • расширить окно осциллографа до размеров примерно 12х10 см, ухватившись за правую его сторону, а потом за нижнюю. Переместить генератор так, чтобы линия связи не имела лишних изгибов;
  • правой кнопкой мыши (или дважды левой) щелкнуть на plot'е (осциллографе), в появившемся окне (рис. 2.12) на вкладке Options (Параметры) поставить галочку у Greed Lines (Сетка координат). Перейти на вкладку Labels (Надписи) (рис. 2.12) и содержательно подписать заголовок (Title). Эта надпись появится в верхней части окна осциллографа;
  • нажать кнопку OK.

Рис. 2.12 (анимация 18 кадров). Настройка осциллографа. Выведение линий координатной сетки на экран и задание названия окна осциллографа

Задание к л.р. №1 > Методические указания

2.3.7. Первая модель

Рис. 2.13. Оформленная диаграмма первого простого лабораторного стенда. Отметим, что метки под блоком генератора указывают, что частота его сигнала равна 12 рад/сек, а амплитуда 2.3 условных единиц, например вольт. Если меток под блоком не видно, то нужно поставить галочку View (Вид) ® Block Labels (Метки блока)

Первый простой лабораторный стенд создан. Можно сделать предварительный вывод о том, что модель работает.

Сохранить сделанные изменения: выбрать File – Save. Убедиться, что в личной папке имеется файл с названием Lab1_2_Gen_sin.vsm.


5 Проверка работоспособности блоков

2.4. Проверка работоспособности некоторых блоков

  • 2.4.1. Количественная проверка работоспособности генератора и осциллографа
  • 2.4.2. Исследование генераторов постоянного сигнала
  • 2.4.3. Первая диаграмма

Задание к л.р. №1 > Методические указания

2.4.1. Количественная проверка работоспособности генераторов и осциллографа

Сохранить предыдущую диаграмму под названием Lab1_3_Gen_sin.vsm для того, чтобы изменения вносить уже в новую диаграмму.

Из сравнения рис. 2.10 и рис. 2.13. видно, что увеличение частоты виртуального генератора в окне рис. 2.11 приводит к соответствующему изменению изображения на экране осциллографа. Остается убедиться в том, что частота синусоидального сигнала, изображенного на рис. 2.13 действительно численно равна той, которая была ранее установлена в диалоговом окне генератора рис. 2.11. Размер рис.2.13 позволят определить период не очень точно, как видно, он примерно равен 0.52 сек. Следовательно, частота сигнала, изображенного на осциллографе, приближенно равна w = 2p/0.52 = 12.08 рад/сек. Таким образом, точность работы модели по крайней мере, не хуже, чем 1 %. На самом деле точность, конечно, значительно выше, поскольку и результаты можно прочитать значительно точнее. Для повышения точности считывания величины периода можно развернуть окно осциллографа на весь экран. О других способах повышения точности отсчетов см. ниже п. 2.6.1.

Провести исследование и построить зависимость частоты сигнала, определенной по экрану осциллографа от величины частоты сигнала генератора, задаваемой в его диалоговом окне. Результаты измерений занести в таблицу, форму которой создать самостоятельно. Построить и привести в отчете график этой зависимости, оценить среднеквадратическое отклонение результатов от прямой теоретической линии. Сделать выводы о точности моделирования синусоиды в VisSim’е и точности считывания результатов с экрана осциллографа, а также о том, выполняют ли свои функции осциллограф и генератор.

Примечание. Предложенное исследование скорее ставит вопрос о возможности "экспериментальной" проверки качества моделирования элементов реальных систем с помощью виртуальных устройств и приборов, нежели дает всестороннее подтверждение состоятельности, работоспособности блоков. Тем не менее, общее представление о такой процедуре оно создает. Поэтому, в дальнейшем можно говорить, например, о проведении виртуальных измерений сигналов.

Дополнительное задание. Предложите методику проверки правильности вывода значений синусоидального сигнала на экране осциллографа. Обобщите ее на случай известного сигнала произвольной формы.

Задание к л.р. №1 > Методические указания

2.4.2. Исследование генераторов постоянного сигнала

Добавить на рабочее пространство блоки: генератор постоянного сигнала constant (константа) и регулируемый генератор постоянного сигнала slider (ползунок) (Blocks ® Signal Producer ® ...) и подключить их к осциллографу.

Эти блоки отличаются тем, что выходной сигнал первого нельзя изменять, когда модель запущена в работу, а второго – можно, перемещая движок с помощью мыши. Т.о. "ползунок" позволяет исследователю вмешиваться в ход работы модели в процессе ее функционирования. До запуска модели можно менять величины выходных сигналов у обоих генераторов.

Запустить модель на счет. Поэкспериментировать, изменяя значения выходного сигнала генератора константы constant, величину и пределы изменения выходного сигнала регулируемого генератора постоянного сигнала слайдера ("ползунка"), и наблюдая за изменением показаний осциллографа при повторных запусках процесса моделирования. Для изменения пределов выходного сигнала слайдера следует щелкнуть по нему дважды левой (или один раз правой) кнопкой мыши и в появившемся окне ввести значения верхней границы диапазона Upper Bound и нижней Lover Bound. Эти значения не обязательно должны быть равными по величине. Уменьшение диапазона выходного сигнала "ползунка" упрощает точную установку малых значений его выходного сигнала.

Рис. 2.14. Изменение верхней и нижней границ диапазона выходного сигнала слайдера ("ползунка")

Провести измерения и построить зависимости показаний осциллографа от величин выходных значений генераторов постоянных сигналов, устанавливаемых в их диалоговых окнах. Проанализировать графики и сделать выводы.

Задание к л.р. №1 > Методические указания

2.4.3. Первая диаграмма

Ввести надписи для блоков генераторов.

Рис. 2.15. Первая диаграмма закончена и готова к сохранению. Как видно, осциллограф действительно отображает выходные сигналы генераторов. Т.о., можно утверждать, что виртуальный лабораторный стенд, построенный в программе VisSim, действует и работает правильно

Сохранить диаграмму Lab1_3_Gen_sin.vsm: File - Save As.

Сделать снимок экрана, подобный рис. 2.15 и сохранить его с содержательным названием, например Lab1_3_Gen_sin.gif. в формате gif в личной папке. Порядок сохранения снимка экрана приведен в [5]. Снимок экрана необходим для распечатки диаграммы на бумаге, с тем, чтобы приложить его к отчету по работе. Чтобы распечатка получилась четкой, следует располагать блоки по возможности плотнее.


6 Индикаторы

Задание к л.р. №1 > Методические указания

2.5. Создание новой диаграммы. Знакомство с цифровым индикатором и стрелочным прибором

Открыть новую диаграмму: File – Open (Открыть) или щелкнуть по кнопке [image] на панели инструментов VisSim. Если предыдущая диаграмма была сохранена, то появится новое пустое рабочее пространство, в противном случае программа VisSim может спросить следует ли сохранить предыдущую диаграмму. Ее нужно сохранить в личной папке и открыть новую диаграмму.

Поместить на рабочее пространство стрелочный прибор meter и цифровой индикатор display: Blocks ® Signal Consumer ® meter (или display). Вынести регулируемый генератор постоянного сигнала (Blocks ® Signal Producer ® slider) и подключить стрелочный прибор и цифровой индикатор к выходу этого генератора (рис. 2.17).

Изменить предел измерений стрелочного прибора, так чтобы он мог измерить выходной сигнал слайдера, величиной 32 единицы: Upper Bound (Верхний предел) установить равным 100. Для этого, дважды щелкнуть по блоку "ползунка" (slider). Подписать название единиц измерения Axis Label (значения шкалы измерений): Напряжение, В, а также название стрелочного прибора в поле ввода Window Title (Заголовок окна): Вольтметр.

Растянуть окно стрелочного прибора для повышения точности чтения его показаний.

Рис. 2.16. Увеличение предела измерений стрелочного прибора и обозначение единиц измерений

Рис. 2.17 (анимация 26 кадров). Вторая диаграмма. Индикаторы действительно показывают величину выходного сигнала регулируемого генератора постоянного напряжения. Если присмотреться, то видно, что стрелочный прибор реагирует на изменения выходного сигнала генератора сразу, по мере смещения ползунка мышкой, в то время как цифровой индикатор более инерционен

Запустить на счет.

Изменять значение выходного сигнала генератора, каждый раз запуская моделирование. Оценить точность чтения показаний цифровым индикатором и стрелочным прибором.

Сохранить диаграмму, назвав содержательно файл, например, Lab1_Indic.vsm. Сделать снимок экрана и сохранить его в файле Lab1_Indic.gif с расширением gif.

По возможности вычислительного зала распечатать снимок экрана и приложить его к отчету. Или начертить диаграмму в отчете.

Задание к л.р. №1 > Методические указания


7 Время и шаг интегрирования

Задание к л.р. №1 > Методические указания

2.6. Изменение продолжительности функционирования модели и шага интегрирования

Одни реальные системы или объекты могут жить и работать очень малые доли секунды, другие функционируют минуты, часы – годы и т.д. Соответственным должно быть и модельное время, время, в течение которого модель работает. Т.о. необходимо иметь возможность менять продолжительность работы модели. Модель в VisSim’е может функционировать как в реальном времени, так и просчитываться ускоренно.

Точность и даже правильность модели, ее соответствие реальной системе зависят и от величины шага интегрирования. При достаточно малом шаге модель, построенная в соответствии с функциональной схемой реальной системы, работает правильно. Если шаг необоснованно завысить, то модель будет просчитываться быстро, но даст неточные и даже не правильные результаты. Слишком малый шаг приводит к чрезмерному увеличению продолжительности расчетов.

Изменить время функционирования модели: Simulate (Моделировать) ® Simulation Properties (Свойства моделирования) ® Range End (Время конца моделирования) рис. 2.18. Установить время конца моделирования равным 2 сек.

Нажать ОК.

Щелкнуть по кнопке с зеленым треугольником "Пуск". Убедиться, что длительность развертки осциллографа стала равной 2 сек. Обратим внимание на возможность установки галочки в пункте рис. 2.18 Run in Real Time (Запуск в реальном времени), в этом случае модельная секунда будет длиться столько же, сколько и реальная.

Рис. 2.18. Задание шага интегрирования Step Size и времени конца End работы модели. Зачастую момент начала моделирования, т.е. время старта Start имеет смысл оставлять равным нулю, тогда время конца моделирования End совпадает с полным временем моделирования. Установка галочки в пункте Run in real Time (Запуск в реальном времени) поддерживает модельное время равным реальному.

Изменить величину шага интегрирования. Выбрать Simulate ® Simulation Properties и установить величину шага Step Size (Величина шага интегрирования) равной 0.001 (рис. 2.18). Отметим, что чем меньше шаг интегрирования, тем точнее будут получаться результаты, но тем медленнее компьютер будет вычислять значения сигналов блоков модели. Поэтому целесообразно уменьшать шаг интегрирования только до тех пор, пока дальнейшее уменьшение не будет приводить к заметному изменению результатов, например вида кривой на осциллографе.

Щелкнуть ОК.

Величина шага интегрирования и продолжительность моделирования – важные параметры, которые нужно уметь правильно подбирать, ориентируясь на характерные и наименьшие постоянные времени элементов модели и модели в целом.

Для первой диаграммы, рис. 2.15, последовательно задать значения шага интегрирования, равными 0.1; 0.01; 0.001; 0.0001 сек. Сравнить диаграммы и сделать вывод об оптимальном значении шага интегрирования в данном случае.

Рис. 2.19 (анимация 5 кадров). Последовательное десятикратное уменьшение шага интегрирования с 0.1 до 0.0001 сек показывает, что для синусоидального сигнала рассматриваемой частоты 12 рад/сек оптимальным значением шага является 0.001 сек. Поскольку период синусоиды составляет примерно 0.5 сек, то при шаге интегрирования в 0.1 сек график на периоде проводится только через 7 точек, что явно не достаточно. Значение 0.01 сек значительно улучшает представление графика, при уменьшении шага от 0.001 до 0.0001 график практически не изменяется. Оптимальным значением шага в данном случае является 0.001 сек

Задание к л.р. №1 > Методические указания


8 Настройки и приемы работы

2.7. Полезные приемы и настройки

  • 2.7.1. Управление осциллографом и его настройки
  • 2.7.2. Копирование блоков и фрагментов модели

Задание к л.р. №1 > Методические указания

2.7.1. Управление осциллографом и некоторые его настройки

    • Свойства осциллографа. Вкладка Параметры (Options)
    • Свойства осциллографа. Вкладка Axis (Оси)
    • Свойства осциллографа. Вкладка Appearance (Внешний вид)

Виртуальный осциллограф VisSim’а способен выполнять много разных функций, решать различные задачи. Прежде всего, это многолучевой осциллограф с автоматической настройкой. Настоящий осциллограф такого класса может стоить несколько сотен или даже тысяч долларов. Размер окна осциллографа целесообразно устанавливать примерно 12х10 см с тем, чтобы он вместе с моделью не выходил за рамки одного экрана. Это делает и диаграмму обозримой, и точность чтения результатов с осциллографа довольно высокой.

Задание к л.р. №1 > Методические указания

Свойства осциллографа. Вкладка Параметры (Options)

Для изменения настроек, заложенных в осциллограф по умолчанию, как исходные, следует щелкнуть правой (или дважды быстро левой) клавишей мыши по окну осциллографа на рабочем пространстве. Появится диалоговое окно, открытое на вкладке Options (Параметры):

Рис. 2.20. Вкладка параметров свойств осциллографа. Выделены полезные элементы управления осциллографом. Прежде всего, это возможность создания сетки координат Grid Lines.

При начальном освоении VisSim’а здесь достаточно проставлять галочку создания сетки координат Grid Lines (Линии сетки) и щелкать по клавише ОК.

Значения координат точек можно прочитать значительно точнее, щелкнув по кнопке Read Coordinates (Читать координаты). Появившееся перекрестие наводят на точку, координаты которой определяют, и щелкают левой клавишей для фиксации перекрестия. Внизу окна осциллографа выводятся значения координат точки. Щелчок по окну осциллографа перекрестие убирает.

Рис. 2.21. Чтение значений координат точек

Кроме того, точность чтения повышается при развертке экрана осциллографа на все рабочее пространство VisSim’а.

Еще один способ повышения точности чтения – увеличение фрагмента экрана осциллографа на весь его экран. Для этого следует, нажав и удерживая клавишу Ctrl (Контроль), выделить левой кнопкой мыши фрагмент экрана и отпустить кнопку, а потом клавишу Ctrl. Это можно проделывать последовательно неоднократно. Для возвращения к исходному масштабу следует, удерживая клавишу Ctrl, щелкнуть по окну осциллографа правой кнопкой.

На экран осциллограф можно поочередно вывести несколько графиков (см. для примера рис. 2.19).

Для этого следует поставить галочку в пункте Over Plot (Поверх графика) (см. рис. 2.20), щелкнуть ОК, запустить модель, изменить параметр модели, перенести линию соединения с одного входа осциллографа на другой и вновь запустить модель. Для очистки экрана осциллографа следует щелкнуть по кнопке Clear Overplot рис. 2.20.

Отметим также возможности перевода градуировки осей из натурального в логарифмический масштаб, проставления кривой не точками, а другими символами, возможность подачи сигналов не только на вертикальную, но и на горизонтальную развертку, а также сохранения значений координат точек кривой в текстовом файле.

Задание к л.р. №1 > Методические указания

Свойства осциллографа. Вкладка Axis (Оси)

При окончательном оформлении диаграммы бывает полезно уточнить значения градуировки осей, отменив автоматическую их разметку и перейдя в режим ручного управления. Для этого, на вкладке Axis (Оси) устанавливают значения верхних (Upper) и нижних (Lower) границ (Bound) развертки по соответствующим осям.

Рис. 2.22. Уточнение разметки осей в ручном режиме. Количество делений при выбранном пункте Fixed Tick Count (Фиксированное число делений), например по вертикальной оси Y: Y Divisions, следует выбирать таким, чтобы результат деления диапазона на эту величину был круглым: 0.2; 0.5; 1; 2; 5; 10 и т.п. Это упрощает чтение значений координат точек

Задание к л.р. №1 > Методические указания

Свойства осциллографа. Вкладка Appearance (Внешний вид)

В некоторых случаях, для повышения наглядности, реалистичности внешнего вида окна осциллографа можно изменить в нем цвет надписей (Foreground) и цвет заднего плана (Background) при установленной галочке Override default colors (Переназначение исходных цветов):

Рис. 2.23. Изменение цветовой гаммы окна осциллографа

В результате может быть получен, например, такой вид окна осциллографа:

Рис. 2.24. Цветовая гамма окна осциллографа, может быть и не очень эстетичная, выбрана исследователем

Задание к л.р. №1 > Методические указания

2.7.2. Копирование и перемещение одного или нескольких блоков

Отметим, что для ускорения работы, блоки, помешенные на рабочем столе, можно копировать и вставлять как в эту же диаграмму, так и в другую диаграмму, открытую в другом экземпляре VisSim. Для этого нужно выделить один или несколько блоков, щелкнуть по кнопке Копировать (Copy) вверху, на панели инструментов VisSim, а затем там же по кнопке Вставить (Paste) и перенести копию блоков (пунктирный прямоугольник) на нужное место и зафиксировать ее щелчком левой клавиши.

Рис. 2.25 (анимация, 37 кадров). Выделение, копирование и вставка на рабочее пространство фрагмента модели

Выделенные блоки можно перемещать как совокупность, не меняя при этом их взаимного расположения.


9 Справка и примеры диаграмм

Задание к л.р. №1 > Методические указания

2.8. Знакомство со справкой о программе VisSim и примерами диаграмм

В меню VisSim выбрать Help – Contents. Ознакомиться с оглавлением, просмотреть отдельные разделы. Существует русская версия файла помощи VisSim [6]. Файл находится в той же папке, откуда был запущен файл настоящей лабораторной работы. Следует открыть этот файл и познакомиться с его содержанием и отдельными разделами.

В папке C:\VisSim_FAP30\VisSim30\, в которой помещены файлы программы VisSim, имеется папка Appexmpl, в последней помещено много примеров моделей. Полезно их запустить и рассмотреть.

Обратим внимание на такие примеры:

  • BOUNCE_30.VSM
    Это пример решения задачи по физике о прыгающем мяче, в котором учитывается сопротивление воздуха, упругость мяча, сила тяжести и др. Параметры задачи можно изменять, что позволяет исследовать их влияние на характер поведения прыгающего мяча.
  • PWM_EX_30.VSM
    Это пример преобразования синусоидального сигнала в сигнал с широтно-импульсной модуляцией.

Примечание. Для того, чтобы запустить эти диаграммы, следует щелкнуть дважды по их названию, в появившемся диалоговом окне

выбрать "Сохранить" и сохранить их в личной папке. Запустить VisSim и из него открыть диаграмму.

Дело в том, что случается, что некоторые "умники" изменяют настройки операционной системы и она, при двойном щелчке по файлу диаграммы, пытается открыть его не VisSim'ом, а другой программой. В результате ничего не получается.

Задание к л.р. №1 > Методические указания

2.9. Выводы по проделанной работе и оформление отчета

Сделать выводы на сновании решения поставленных в работе цели и задач. Нужно отличать выводы от констатации фактов, из которых и следуют выводы.

Выводы следует формулировать в технической форме, а не в методической, используя безличную форму изложения. Например, вывод может быть такой: “Блоки VisSim’а генератор синусоиды (sinusoid) и осциллограф (plot) действительно являются виртуальными аналогами реальных устройств” или, по крайней мере, такой: "Изменяющиеся сигналы целесообразнее исследовать с помощью осциллографа, а постоянные - с помощью цифрового индикатора". Не следует констатировать что-то в виде: "Мы (а тем более, Я) познакомились, научились и т.п. ...".

Задание к л.р. №1 > Методические указания


Федосов Борис Трофимович

Федосов Борис Трофимович Родился в 1950г., в г. Калининграде, Калининградской обл., РСФСР

В 1954 г. приехал в Кустанайскую обл. с родителями на целину.

Учился в школах № 7 и №6 г. Рудного и в г. Ленинграде (шк.№331 - 1кл., шк.№497 - 7 кл.) Окончил 10 класс в физматшколе № 165 в Академгородке Новосибирска в 1967 г.

Окончил Новосибирский электротехнический институт в 1973 г., инженер-радиотехник.

С 1973 работает в г. Рудном в РИИ: старшим лаборантом кафедры ЭАГР; с 1974 г. - преподавателем, старшим преподавателем, зав. кафедрой (1982 - 1985г.) высшей геодезии РИИ.

1980 г. - защитил кандидатскую диссертацию в Московском институте инженеров геодезии, аэрофотосъемки и картографии. Тема диссертации: "Разработка и исследование светодальномеров с активным ответом".

1985 - 1990 г. - зав. кафедрой электротехники РИИ.

1991 г. - доцент кафедры АТПиП.

Трудов и изобретений - 22. Основные работы в областях: светодальномерная техника, оптическая длинобазисная интерферометрия.

Читал курсы: радиогеодезии; автоматизации высокоточных инженерно-геодезических измерений; электротехники; ТАУ; телемеханики; программирования и вычислительной техники и др.

E-mail: defbort@mail.kz

Кафедра АТПиП

459120; Казахстан;
Костанайская область; г. Рудный;
ул. 50 Лет Октября 52,54;
Рудненский индустриальный институт;
телефон (8-31431) 5-04-01 (доб.131)
или 5-02-80 (доб.131)
URL:http://web.host.kz/atpp
E-mail:atpp@mail.kz

Клиначёв Николай Васильевич Клиначёв Николай Васильевич,
к.т.н., доцент кафедр "Электротехника" и "Информатика" ЮУрГУ
т.р. (3512)67-90-14, т.д. (3512)34-71-62; <klinacherv_nv@mail.ru>

Основные преподаваемые дисциплины:

1) "Электротехника и электроника",
2) "Электрические и электронные аппараты",
3) "Управление техническими системами",
4) "Математические основы ТАУ",
5) "Аналоговые и аналогово-цифровые интегральные микросхемы",
6) "Информатика".

Специальность: Системы обработки информации и управления

Сфера профессиональных интересов:

Все уровни разработки любой электроники любыми методами на любой элементной базе. Программирование: C++, Pascal, Java, VB, JavaScript, HTML, ассемблеры, эмуляторы, отладчики; интегрированные среды разработки IDE; CAE/CAD системы, EDA/PCB инструменты; пакеты симулирующие движение; SCADA пакеты. Педагогическая деятельность.

Принимал участие в разработке следующих проектов:

  1. Генератор сигналов произвольной формы.
  2. Измерительный комплекс для снятия АФЧХ систем.
  3. Имитатор солнечной батареи - DC/DC (для замещения последней в наземных условиях).
  4. Прибор для измерения контактного сопротивления.
  5. Прибор для измерения удельного сопротивления углеграфитовых изделий.
  6. Прибор для измерения активного сопротивления обмоток электрических машин большой мощности.

Личные проекты:

  1. Cервер "VisSim в России".
  2. Сервер "LabVIEW в России".
  3. Система "ИНТЕРНЕТ-КОЛЛОКВИУМ".
  4. Библиотека измерений ЧХ систем для пакета VisSim.

Методическая работа:

  1. Сервер кафедры "Электротехника".
  2. Выполнение обязанностей модератора почтовых дискуссионных групп и одноименных форумов:
    е-группа "Цифровая обработка сигналов в LabVIEW" (пустое письмо для подписки или ...)
    е-группа "Симуляция движения и моделирование САУ в VisSim-е" (пустое письмо для подписки или...)

Публикации (методические):

  1. Клиначёв Н. В. Электротехника: Контрольно-тестирующая система. - Offline версия 3.0. - Челябинск, 1999. - 671 файл, ил.
  2. Клиначёв Н.В. Моделирование обыкновенных линейных систем. ТАУ, Электроника: Руководство к лабораторным работам в пакетах VisSim и Electronics Workbench. - Челябинск, 2001. (дополнительный адрес).
  3. Клиначёв Н. В. Теория систем автоматического регулирования и управления: Контрольно-тестирующая система. - Offline версия 3.0. - Челябинск, 2001. - 101 файл, ил.
  4. Клиначёв Н. В. Моделирование систем в программе VisSim: Справочная система. - Online версия 1.0. - Челябинск, 2001. - 214 файлов, ил. (архив Offline версии - vsmhlpru.chm).
  5. Литюга А. М., Клиначёв Н. В., Мазуров В. М. Теоретические основы построения эффективных АСУ ТП: Конспект лекций. - Offline версия 1.1. - Тула, Челябинск, 2002. - 703 файла, ил.
  6. Неизвестный автор и Клиначёв Н. В. LabVIEW в упражнениях: Учебное пособие. - Offline версия 1.0. - Челябинск, 2001. - 212 файлов, ил.
  7. Федосов Б. Т., Клиначёв Н. В. Теория систем автоматического регулирования: Руководство к выполнению лабораторных работ. - Offline версия 3.2 для заочного обучения. - Рудный, Челябинск, 2004. - 125 файлов, ил.
  8. Клиначёв Н. В. Теория систем автоматического регулирования и управления: Учебно-методический комплекс. - Offline и Online версии 1.5, 1.6, ..., 3.3. - Челябинск, 2000-2004. - 659 файлов, ил. (дополнительный адрес).
  9. Клиначёв Н. В. Основы моделирования систем или 7 доменов законов Ома и Кирхгофа: Избранные фрагменты. - Offline и Online версии 1.9, 2.0, ..., 3.3. - Челябинск, 2000-2004. - 659 файлов, ил. (Распространяется в одном файле с учебно-методическим комплексом по ТАУ).
  10. Клиначёв Н. В. Библиотека SimLib4Visio - инструмент программирования математических ядер моделирующих программ. - v1.2. - Челябинск, 2004. - 13 файлов.

Год начала преподавательской деятельности:1997

Рабочие языки общения: английский

Адрес: Энгельса 42-31, Челябинск, Россия, 454080